summaryrefslogtreecommitdiff
path: root/main/elinks
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-04-28 18:58:44 +0000
committerpsykose <alice@ayaya.dev>2023-04-28 20:58:52 +0200
commit2ee40cf600f4c7e16da4e4b58f9cb7bfe2f4d81a (patch)
treef57bc2291be0a61721ba98a6ba2e95894b691b86 /main/elinks
parent0f4a2c86592e03ca36a6a3b4ed8b161e3f68bd0c (diff)
downloadaports-2ee40cf600f4c7e16da4e4b58f9cb7bfe2f4d81a.zip
main/elinks: update checksums
small repos change patch checksums when more commits get added..
Diffstat (limited to 'main/elinks')
-rw-r--r--main/elinks/APKBUILD6
-rw-r--r--main/elinks/libidn2.patch111
2 files changed, 114 insertions, 3 deletions
diff --git a/main/elinks/APKBUILD b/main/elinks/APKBUILD
index e1bb15ee1f7..fda53b110a8 100644
--- a/main/elinks/APKBUILD
+++ b/main/elinks/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=elinks
pkgver=0.16.0
-pkgrel=2
+pkgrel=3
pkgdesc="Advanced and well-established feature-rich text mode web browser"
url="https://github.com/rkd77/elinks/"
arch="all"
@@ -22,7 +22,7 @@ makedepends="
"
subpackages="$pkgname-doc $pkgname-lang"
source="https://github.com/rkd77/elinks/releases/download/v$pkgver/elinks-$pkgver.tar.xz
- $pkgname-libidn2.patch::https://github.com/rkd77/elinks/commit/8cb69b38329525ed9def8d53cc16ef6e5804242d.patch
+ libidn2.patch
"
build() {
@@ -45,5 +45,5 @@ package() {
sha512sums="
b1d6040b691610d596e0d1eae26bfe52d702272c71a2e5100ab7d6b05b24a0b88524d4fc7be3f6371e0bada1e6f0992da7505a72419ca642dec778424629a522 elinks-0.16.0.tar.xz
-d124854a282c67bd395a7c742caae879844a25c5b5c406edf93292eee8e92f6755b584d5995ba9affa214d8b96149c9e5c8709ef1088078dfedcb2768ef1f109 elinks-libidn2.patch
+f0be2f109cccd38087c5ef726ace869d1d69836ec18fb30b569f601f1c6031bb565721467249a7b7151622fe6be43df7d561fc3e9a12a4c4a98c6430aebc72e1 libidn2.patch
"
diff --git a/main/elinks/libidn2.patch b/main/elinks/libidn2.patch
new file mode 100644
index 00000000000..834c3885c53
--- /dev/null
+++ b/main/elinks/libidn2.patch
@@ -0,0 +1,111 @@
+From 8cb69b38329525ed9def8d53cc16ef6e5804242d Mon Sep 17 00:00:00 2001
+From: Witold Filipczyk <witekfl@poczta.onet.pl>
+Date: Mon, 2 Jan 2023 17:09:24 +0100
+Subject: [PATCH] [meson] libidn2
+
+---
+ config2.h.in | 6 +++---
+ meson.build | 10 +++++-----
+ src/config/cmdline.c | 10 +++++-----
+ src/protocol/test/meson.build | 2 +-
+ 4 files changed, 14 insertions(+), 14 deletions(-)
+
+diff --git a/config2.h.in b/config2.h.in
+index 09774a4b0..2a445eb3a 100644
+--- a/config2.h.in
++++ b/config2.h.in
+@@ -117,7 +117,7 @@
+ #mesondefine CONFIG_HTML_HIGHLIGHT
+
+ /* Define if you want: idn support */
+-#mesondefine CONFIG_IDN
++#mesondefine CONFIG_IDN2
+
+ /* Define if you want: interlinking support */
+ #mesondefine CONFIG_INTERLINK
+@@ -461,8 +461,8 @@
+ /* Define if you have the iconv() function. */
+ #mesondefine HAVE_ICONV
+
+-/* Define to 1 if you have the <idna.h> header file. */
+-#mesondefine HAVE_IDNA_H
++/* Define to 1 if you have the <idn2.h> header file. */
++#mesondefine HAVE_IDN2_H
+
+ /* Define to 1 if you have the <ifaddrs.h> header file. */
+ #mesondefine HAVE_IFADDRS_H
+diff --git a/meson.build b/meson.build
+index d0d6652ab..eae6ebfa4 100644
+--- a/meson.build
++++ b/meson.build
+@@ -67,7 +67,7 @@ conf_data.set('CONFIG_BZIP2', get_option('bzlib'))
+ conf_data.set('CONFIG_BROTLI', get_option('brotli'))
+
+ conf_data.set('CONFIG_ZSTD', get_option('zstd'))
+-conf_data.set('CONFIG_IDN', get_option('idn'))
++conf_data.set('CONFIG_IDN2', get_option('idn'))
+ conf_data.set('CONFIG_LZMA', get_option('lzma'))
+ conf_data.set('CONFIG_GSSAPI', get_option('gssapi'))
+ conf_data.set('CONFIG_ECMASCRIPT_SMJS', get_option('spidermonkey'))
+@@ -283,8 +283,8 @@ if compiler.has_header('gpm.h')
+ conf_data.set('HAVE_GPM_H', 1)
+ endif
+
+-if compiler.has_header('idna.h')
+- conf_data.set('HAVE_IDNA_H', 1)
++if compiler.has_header('idn2.h')
++ conf_data.set('HAVE_IDN2_H', 1)
+ endif
+
+ if compiler.has_header('event.h')
+@@ -368,8 +368,8 @@ if conf_data.get('CONFIG_LZMA')
+ deps += lzmadeps
+ endif
+
+-if conf_data.get('CONFIG_IDN')
+- idndeps = dependency('libidn', static: st)
++if conf_data.get('CONFIG_IDN2')
++ idndeps = dependency('libidn2', static: st)
+ deps += idndeps
+ endif
+
+diff --git a/src/config/cmdline.c b/src/config/cmdline.c
+index 424bde6ab..37a8da53a 100644
+--- a/src/config/cmdline.c
++++ b/src/config/cmdline.c
+@@ -16,8 +16,8 @@
+ #include <netdb.h>
+ #endif
+
+-#ifdef HAVE_IDNA_H
+-#include <idna.h>
++#ifdef HAVE_IDN2_H
++#include <idn2.h>
+ #endif
+
+ /* We need to have it here. Stupid BSD. */
+@@ -168,11 +168,11 @@ lookup_cmd(struct option *o, char ***argv, int *argc)
+
+ idname = *(*argv - 1);
+
+-#ifdef CONFIG_IDN
++#ifdef CONFIG_IDN2
+ if (idname) {
+- int code = idna_to_ascii_lz(idname, &idname2, 0);
++ int code = idn2_to_ascii_lz(idname, &idname2, 0);
+
+- if (code == IDNA_SUCCESS) {
++ if (code == IDN2_OK) {
+ idname = idname2;
+ allocated = 1;
+ }
+diff --git a/src/protocol/test/meson.build b/src/protocol/test/meson.build
+index b34b5199e..bdcf8ee08 100644
+--- a/src/protocol/test/meson.build
++++ b/src/protocol/test/meson.build
+@@ -1,4 +1,4 @@
+-idna_dep = dependency('libidn')
++idna_dep = dependency('libidn2')
+
+ uri_test_files = files('uri-test.c', 'stub.c', meson.current_source_dir()+'/../protocol.cpp', meson.current_source_dir()+'/../uri.c')
+