summaryrefslogtreecommitdiff
path: root/main/efivar/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-05-28 13:38:13 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-05-28 13:40:02 +0000
commit792c5233bf671da4f974c0a7b5e52b9daa1bc4dd (patch)
tree1791ed6599a28d9cb5b2569f03784efa632eed78 /main/efivar/APKBUILD
parentcc85bddbc4c349c05399b3675f531771079e24cd (diff)
downloadaports-792c5233bf671da4f974c0a7b5e52b9daa1bc4dd.zip
main/{efivar,efiboomgr}: move from community
we want efibootmgr on the extended iso image so those needs to be in main.
Diffstat (limited to 'main/efivar/APKBUILD')
-rw-r--r--main/efivar/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/main/efivar/APKBUILD b/main/efivar/APKBUILD
new file mode 100644
index 00000000000..510de1d2d8d
--- /dev/null
+++ b/main/efivar/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Lucas Ramage <ramage.lucas@protonmail.com>
+pkgname=efivar
+pkgver=37
+pkgrel=2
+pkgdesc="Tools and library to manipulate EFI variables"
+url="https://github.com/rhboot/efivar"
+arch="x86 x86_64 armhf armv7 aarch64 ppc64le"
+license="LGPL-2.1"
+depends=""
+depends_dev=""
+makedepends="$depends_dev popt-dev linux-headers"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="https://github.com/rhboot/efivar/releases/download/$pkgver/efivar-$pkgver.tar.bz2
+ efivar-fix-format_guid.patch
+ efivar-fix-packed.patch
+ musl-bswap.patch
+ efivar-fix-ucs2.patch
+ "
+builddir="$srcdir/efivar-$pkgver"
+
+build() {
+ cd "$builddir"
+ libdir="/usr/lib" make
+}
+
+package() {
+ cd "$builddir"
+ libdir="/usr/lib" make DESTDIR="$pkgdir" install
+}
+
+check() {
+ LD_LIBRARY_PATH="$builddir"/src \
+ "$builddir"/src/efivar --help > /dev/null
+}
+sha512sums="305a82ed103c7e3d8f723934019d552677c73558768dd5341f87d0364f5c60824d24f5a8e1bf90075e825908085083d4ecdccec5ac757fd38ee6ac8fea28c3e4 efivar-37.tar.bz2
+78f8f1e41e088440802815fab1e1474b1c98a9362c7bac178ea5eb9c457ad3045e21f2ee700dc95b9e805339e976f0218b6faad663f2f99838ddfa85ce12bb14 efivar-fix-format_guid.patch
+0be6e0fe6f2619bcedaf97006afaeeca2d195a90636ecc73b598c3157abaf55bb956f67e6ab12f680c9c874e496ce2093ee2ba6940a170fd9fed0165bbbcca97 efivar-fix-packed.patch
+84fd5baf91df91889cfcfed2bcf59f073dc754f6aba1944059203bbe99f4bbb6dc92addff9fae8f687a2c95f9438b0eb301dd0320728a8a2a6edd5e2b2b5ba94 musl-bswap.patch
+4eb0459bbffe5a11ecaf004be0ec8589f7439629732fb07944390d7d354537e8318b7f3b6d0729672f12a7b927f0d2907fe5b517aa6f6e9cc1d64b525f3c79ce efivar-fix-ucs2.patch"