summaryrefslogtreecommitdiff
path: root/main/efibootmgr
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-05-28 13:38:13 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-05-28 13:40:02 +0000
commit792c5233bf671da4f974c0a7b5e52b9daa1bc4dd (patch)
tree1791ed6599a28d9cb5b2569f03784efa632eed78 /main/efibootmgr
parentcc85bddbc4c349c05399b3675f531771079e24cd (diff)
downloadaports-792c5233bf671da4f974c0a7b5e52b9daa1bc4dd.zip
main/{efivar,efiboomgr}: move from community
we want efibootmgr on the extended iso image so those needs to be in main.
Diffstat (limited to 'main/efibootmgr')
-rw-r--r--main/efibootmgr/APKBUILD36
-rw-r--r--main/efibootmgr/efivar.patch14
-rw-r--r--main/efibootmgr/musl-gettext.patch11
3 files changed, 61 insertions, 0 deletions
diff --git a/main/efibootmgr/APKBUILD b/main/efibootmgr/APKBUILD
new file mode 100644
index 00000000000..38be6c2b032
--- /dev/null
+++ b/main/efibootmgr/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Lucas Ramage <ramage.lucas@protonmail.com>
+pkgname=efibootmgr
+pkgver=17
+pkgrel=0
+pkgdesc="Linux user-space application to modify the Intel Extensible Firmware Interface"
+url="https://github.com/rhboot/efibootmgr"
+arch="x86 x86_64 armhf armv7 aarch64"
+license="GPL-2.0"
+depends=""
+makedepends="efivar-dev linux-headers popt-dev gettext-dev"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/rhboot/$pkgname/archive/$pkgver.tar.gz
+ musl-gettext.patch
+ efivar.patch"
+builddir="$srcdir/efibootmgr-$pkgver"
+
+build() {
+ cd "$builddir"
+ PCDIR=/usr/lib/pkgconfig EFIDIR="/boot/efi" make
+}
+
+package() {
+ cd "$builddir"
+ EFIDIR="/boot/efi" make DESTDIR="$pkgdir" install
+}
+
+check() {
+ "$builddir"/src/efibootdump --help > /dev/null
+ "$builddir"/src/efibootmgr --help > /dev/null
+}
+
+sha512sums="10c7ad9a79f23dcd4708dc4f42701196af7aa11f5e9a6468ea51f7013d4caeba6c92527ba1304f6e3b2ef3b51b3b69ea1a30f81bb099a8aea49eeb30eb631e1d efibootmgr-17.tar.gz
+3ed49c6d267e6f14bf43207fecb55ebc984f6fbd15d77cd1b8f466c8d0a4c3ab9bb276e8ed183b5ab0129fde5c06ffcd0450ffb7dad0edfa18b4c472e481373b musl-gettext.patch
+a8f4b37e9c0c55a3b2d20f733606653add0219066b9a46b0878885023480747936ad015a52363ceece481ae4d8b702aaa710d9fde2334aae48f97f650416e129 efivar.patch"
diff --git a/main/efibootmgr/efivar.patch b/main/efibootmgr/efivar.patch
new file mode 100644
index 00000000000..614195f3c99
--- /dev/null
+++ b/main/efibootmgr/efivar.patch
@@ -0,0 +1,14 @@
+diff --git a/src/efibootmgr.c b/src/efibootmgr.c
+index de38f01..4e1a680 100644
+--- a/src/efibootmgr.c
++++ b/src/efibootmgr.c
+@@ -1536,9 +1536,6 @@ parse_opts(int argc, char **argv)
+ "invalid numeric value %s\n",
+ optarg);
+ }
+- /* XXX efivar-36 accidentally doesn't have a public
+- * header for this */
+- extern int efi_set_verbose(int verbosity, FILE *errlog);
+ efi_set_verbose(opts.verbose - 2, stderr);
+ break;
+ case 'V':
diff --git a/main/efibootmgr/musl-gettext.patch b/main/efibootmgr/musl-gettext.patch
new file mode 100644
index 00000000000..c14db8278f5
--- /dev/null
+++ b/main/efibootmgr/musl-gettext.patch
@@ -0,0 +1,11 @@
+--- ./Make.defaults.orig
++++ ./Make.defaults
+@@ -49,7 +49,7 @@
+ $(call pkg-config-ccldflags)
+ CPPFLAGS?=
+ SOFLAGS=-shared
+-LDLIBS=$(foreach lib,$(LIBS),-l$(lib)) $(call pkg-config-ldlibs)
++LDLIBS=$(foreach lib,$(LIBS),-l$(lib)) $(call pkg-config-ldlibs) -lintl
+
+ .PHONY: check_efidir_error
+ check_efidir_error : ; $(EFIDIR_ERROR) $(info Building with EFIDIR as $(EFIDIR))