summaryrefslogtreecommitdiff
path: root/main/curl
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2020-06-06 20:02:50 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2020-06-06 18:22:46 +0000
commit0fc214f6ad7edf331a3631041afcd91f5dfc2996 (patch)
tree655e3f2e2a5d925e80cae1a6d9c38a61471382c1 /main/curl
parent1f4aaf37c46ed8730a96a328a8911e75bc9a9204 (diff)
downloadaports-0fc214f6ad7edf331a3631041afcd91f5dfc2996.zip
main/curl: fix tests
add patch sent to me from upstream author which fixes regression introduced upstream
Diffstat (limited to 'main/curl')
-rw-r--r--main/curl/APKBUILD7
-rw-r--r--main/curl/pidfile.patch25
2 files changed, 30 insertions, 2 deletions
diff --git a/main/curl/APKBUILD b/main/curl/APKBUILD
index 1c629c40c76..1f5b23109e4 100644
--- a/main/curl/APKBUILD
+++ b/main/curl/APKBUILD
@@ -14,7 +14,9 @@ depends_dev="openssl-dev nghttp2-dev zlib-dev"
checkdepends="python3"
makedepends="$depends_dev autoconf automake groff libtool perl"
subpackages="$pkgname-dbg $pkgname-static $pkgname-doc $pkgname-dev libcurl"
-source="https://curl.haxx.se/download/curl-$pkgver.tar.xz"
+source="https://curl.haxx.se/download/curl-$pkgver.tar.xz
+ pidfile.patch
+ "
# secfixes:
# 7.66.0-r0:
@@ -128,4 +130,5 @@ static() {
mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib
}
-sha512sums="ab8796af1bd6f35ae704fd5e3639a8153482615a05c24e2e6d0b9cef8ed9a1e0d497ead2dbf5972cc53f632c2d87f0bf79e9e7cac625452dd24e6c7d8045cfc6 curl-7.70.0.tar.xz"
+sha512sums="ab8796af1bd6f35ae704fd5e3639a8153482615a05c24e2e6d0b9cef8ed9a1e0d497ead2dbf5972cc53f632c2d87f0bf79e9e7cac625452dd24e6c7d8045cfc6 curl-7.70.0.tar.xz
+068deb247b42585ccd4b9403a744ab6d2b8effec4f99cb5bb07daa58e71fad9f637896d47d2ad9c9ba8f0ebbad15c0fde997d9def8d6dc6d9b7dc0d75b7f00e9 pidfile.patch"
diff --git a/main/curl/pidfile.patch b/main/curl/pidfile.patch
new file mode 100644
index 00000000000..99102da5bd6
--- /dev/null
+++ b/main/curl/pidfile.patch
@@ -0,0 +1,25 @@
+From 116e735d39c66f582f1f0ed38fa9a1dca946661e Mon Sep 17 00:00:00 2001
+From: Daniel Stenberg <daniel@haxx.se>
+Date: Fri, 5 Jun 2020 23:03:04 +0200
+Subject: [PATCH] server/util: fix logmsg format using curl_off_t argument
+
+... this caused segfaults on armv7.
+
+Regression added in dd0365d560aea5a (7.70.0)
+---
+ tests/server/util.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/server/util.c b/tests/server/util.c
+index 75f3cb1b663..414d7194ff6 100644
+--- a/tests/server/util.c
++++ b/tests/server/util.c
+@@ -290,7 +290,7 @@ int write_pidfile(const char *filename)
+ #endif
+ fprintf(pidfile, "%" CURL_FORMAT_CURL_OFF_T "\n", pid);
+ fclose(pidfile);
+- logmsg("Wrote pid %ld to %s", pid, filename);
++ logmsg("Wrote pid %" CURL_FORMAT_CURL_OFF_T " to %s", pid, filename);
+ return 1; /* success */
+ }
+