summaryrefslogtreecommitdiff
path: root/main/compiler-rt
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-07-30 08:38:13 +0000
committerpsykose <alice@ayaya.dev>2022-07-30 10:41:11 +0200
commitb2f01c65b3957eac5c921b86d45f4b7825671476 (patch)
treeeb6bc7bfbed243ca9fddfd8e46500d7bfb6cf25c /main/compiler-rt
parentd9fdac51a4b24890d373cbf84140752876b3041b (diff)
downloadaports-b2f01c65b3957eac5c921b86d45f4b7825671476.zip
main/compiler-rt: remove execinfo support
see: https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/36722 https://www.openwall.com/lists/musl/2021/07/16/1 https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/22958 note: this is only used by GWPAsan (scudo, -fsanitize=scudo)- not any others, anyway. and even with execinfo, it's broken and hangs on start
Diffstat (limited to 'main/compiler-rt')
-rw-r--r--main/compiler-rt/APKBUILD7
-rw-r--r--main/compiler-rt/link-execinfo.patch11
2 files changed, 3 insertions, 15 deletions
diff --git a/main/compiler-rt/APKBUILD b/main/compiler-rt/APKBUILD
index c363680d612..3efbba44e05 100644
--- a/main/compiler-rt/APKBUILD
+++ b/main/compiler-rt/APKBUILD
@@ -5,7 +5,7 @@
pkgname=compiler-rt
# Note: Update together with llvm.
pkgver=14.0.6
-pkgrel=0
+pkgrel=1
_llvmver=${pkgver%%.*}
pkgdesc="LLVM compiler-rt runtime libraries"
arch="all"
@@ -14,7 +14,6 @@ license="Apache-2.0"
makedepends="
clang
cmake
- libexecinfo-dev
linux-headers
llvm-dev~$_llvmver
llvm-static~$_llvmver
@@ -28,7 +27,6 @@ source="https://github.com/llvm/llvm-project/releases/download/llvmorg-$pkgver/c
https://github.com/llvm/llvm-project/releases/download/llvmorg-$pkgver/llvm-$pkgver.src.tar.xz
xray-ppc64-musl.patch
- link-execinfo.patch
sanitizer-supported-arch.patch
sanitizer-ppc64-musl.patch
"
@@ -58,6 +56,7 @@ build() {
# compiler-rt uses llvm intrinsic types for testing
# and therefore requires clang
# It also needs LLVM source for testing purposes
+ # GWP asan is broken
cmake -G Ninja -B build -Wno-dev \
-DCMAKE_C_COMPILER=clang \
-DCMAKE_CXX_COMPILER=clang++ \
@@ -67,6 +66,7 @@ build() {
-DCOMPILER_RT_BUILD_SANITIZERS=$_build_sanitizers \
-DCOMPILER_RT_BUILD_XRAY=ON \
-DCOMPILER_RT_INSTALL_PATH="/usr/lib/clang/$pkgver" \
+ -DCOMPILER_RT_BUILD_GWP_ASAN=OFF \
-DLLVM_EXTERNAL_LIT="/usr/bin/lit"
cmake --build build
}
@@ -83,7 +83,6 @@ sha512sums="
c0e63071cb99bca837b83fd0e3597cf45cc635f73ab88a1ec48e863a1633f42bd402ea7c5130e8fa0f550b9574c1ecac1799b92b789565e4ead955cf60060907 compiler-rt-14.0.6.src.tar.xz
6461bdde27aac17fa44c3e99a85ec47ffb181d0d4e5c3ef1c4286a59583e3b0c51af3c8081a300f45b99524340773a3011380059e3b3a571c3b0a8733e96fc1d llvm-14.0.6.src.tar.xz
8ed6746474f135ebf77a0888957126ef3a5ded97551632198cf15659104d792487920324b74569dfc46140d26f0a268e2378d6f8878c1c9013b8e6f199eeb3b7 xray-ppc64-musl.patch
-50c68838f79c948b3a0bff6cb120f8c68cac9ad2254d6409b1cddf79cc8a776d1142b29678445d92b62fadc66f353fe89e14dac7aa6c3b4f08d883a06615d7e3 link-execinfo.patch
9aaac8aa9217509cf377b44e20a8c8294b9972e03e9d4f7c1b0ac7c22bcdac6f6a0888ab16b7542e1d6b89a5ac9054c5d8ef8acd1ae1002cca2d0b3df86136a6 sanitizer-supported-arch.patch
aed5efa8a9c4f3bcb3b377d3c69c3fef387ef73d712bb58d60622d02d09f42b827cd810cd0648ca2a0ed6cca794f98a6176522e528488caf2f9ce08e0138c931 sanitizer-ppc64-musl.patch
"
diff --git a/main/compiler-rt/link-execinfo.patch b/main/compiler-rt/link-execinfo.patch
deleted file mode 100644
index 8da49fb38be..00000000000
--- a/main/compiler-rt/link-execinfo.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/lib/scudo/standalone/CMakeLists.txt
-+++ b/lib/scudo/standalone/CMakeLists.txt
-@@ -137,6 +137,8 @@
-
- append_list_if(FUCHSIA zircon SCUDO_LINK_LIBS)
-
-+list(APPEND SCUDO_LINK_LIBS execinfo)
-+
- if(COMPILER_RT_HAS_SCUDO_STANDALONE)
- add_compiler_rt_object_libraries(RTScudoStandalone
- ARCHS ${SCUDO_STANDALONE_SUPPORTED_ARCH}