summaryrefslogtreecommitdiff
path: root/main/bubblewrap
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2022-02-26 15:29:11 -0300
committerLeo <thinkabit.ukim@gmail.com>2022-03-16 15:59:57 +0000
commitd2464a260caa9d39a46c875b84fe683532811d6f (patch)
treeb41ccb065928583a907c91b0d08866b43d105fa9 /main/bubblewrap
parent636ae6a54bc328bdb371a04cf2ca6751d95f7a2c (diff)
downloadaports-d2464a260caa9d39a46c875b84fe683532811d6f.zip
main/bubblewrap: upgrade to 0.6.1
Diffstat (limited to 'main/bubblewrap')
-rw-r--r--main/bubblewrap/APKBUILD27
1 files changed, 8 insertions, 19 deletions
diff --git a/main/bubblewrap/APKBUILD b/main/bubblewrap/APKBUILD
index b3fad96bdef..90ffed7a28e 100644
--- a/main/bubblewrap/APKBUILD
+++ b/main/bubblewrap/APKBUILD
@@ -1,14 +1,14 @@
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=bubblewrap
-pkgver=0.5.0
+pkgver=0.6.1
pkgrel=0
pkgdesc="Unprivileged sandboxing tool"
url="https://github.com/containers/bubblewrap"
arch="all"
license="LGPL-2.0-or-later"
options="!check" # Testsuite fails
-makedepends="autoconf automake libcap-dev docbook-xsl"
+makedepends="meson libcap-dev docbook-xsl"
subpackages="$pkgname-doc $pkgname-bash-completion $pkgname-zsh-completion"
source="bubblewrap-$pkgver.tar.gz::https://github.com/containers/bubblewrap/archive/v$pkgver.tar.gz"
@@ -16,28 +16,17 @@ source="bubblewrap-$pkgver.tar.gz::https://github.com/containers/bubblewrap/arch
# 0.4.1-r0:
# - CVE-2020-5291
-prepare() {
- NOCONFIGURE=1 ./autogen.sh
- default_prepare
-}
-
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- --with-priv-mode=none \
- --enable-require-userns=yes
- make
+ abuild-meson \
+ -Drequire_userns=true \
+ . output
+ meson compile ${JOBS:+-j ${JOBS}} -C output
}
package() {
- make install DESTDIR="$pkgdir"
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
sha512sums="
-9d1faa02aaf78a8005d5f032cfc708d9823b5d110bd35f600a7d075122eeda785db72dd5c5e416a35ade437cd0ff9b176d24aea980971e304600e03c793d1865 bubblewrap-0.5.0.tar.gz
+30743cadc4f536430e253e1e21af5e0e56ae5dc4a11258faa42321b04b7490b54f904e72fc0147b23b0a0524870f41b5805c1482d20a11e0c4549bf8ae1d651f bubblewrap-0.6.1.tar.gz
"