summaryrefslogtreecommitdiff
path: root/main/apache-mod-auth-kerb
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2020-02-26 23:26:48 +0100
committerTBK <tbk@jjtc.eu>2020-03-23 14:33:48 +0100
commit060a0540c54ec24b83caa8da54e3fb376dd1fa03 (patch)
tree3ddd41a5b67c5d62bc22916392d2331ee9417765 /main/apache-mod-auth-kerb
parent90021f2518697d2787dbe8e0d6fef92096ce0bb4 (diff)
downloadaports-060a0540c54ec24b83caa8da54e3fb376dd1fa03.zip
main/apache-mod-auth-kerb: modernize
Diffstat (limited to 'main/apache-mod-auth-kerb')
-rw-r--r--main/apache-mod-auth-kerb/APKBUILD31
-rw-r--r--main/apache-mod-auth-kerb/mod_auth_kerb-5.4-httpd24.patch15
2 files changed, 17 insertions, 29 deletions
diff --git a/main/apache-mod-auth-kerb/APKBUILD b/main/apache-mod-auth-kerb/APKBUILD
index 44cdf0f9b59..126af35d9f3 100644
--- a/main/apache-mod-auth-kerb/APKBUILD
+++ b/main/apache-mod-auth-kerb/APKBUILD
@@ -7,42 +7,29 @@ pkgrel=5
pkgdesc="A Kerberos authentication module for the Apache Http Server"
url="https://sourceforge.net/projects/modauthkerb/"
arch="all"
-license="BSD MIT"
+license="BSD-3-Clause AND MIT"
+options="!check" # No test suite
depends="apache2"
makedepends="apache2-dev krb5-dev"
-source="https://downloads.sourceforge.net/project/modauthkerb/$_pkgname/$_pkgname-$pkgver/$_pkgname-$pkgver.tar.gz
+source="https://downloads.sourceforge.net/project/modauthkerb/mod_auth_kerb/mod_auth_kerb-$pkgver/mod_auth_kerb-$pkgver.tar.gz
mod_auth_kerb-5.4-httpd24.patch
mod_auth_kerb_compile.patch
- mod-auth-kerb.conf"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+ mod-auth-kerb.conf
+ "
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd $srcdir/$_pkgname-$pkgver
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--with-krb5=/usr \
--without-krb4 \
- --with-apache=/usr \
- || return 1
- make -j1 || return 1
+ --with-apache=/usr
+ make
}
package() {
- cd $srcdir/$_pkgname-$pkgver
-# make DESTDIR="$pkgdir" install || return 1
mkdir -p "$pkgdir"/etc/apache2/conf.d
mkdir -p "$pkgdir"/usr/lib/apache2
install -D -m755 ./src/.libs/*.so "$pkgdir"/usr/lib/apache2
@@ -50,6 +37,6 @@ package() {
}
sha512sums="93fdf0e43af1c24e8c8204d09240b708747068ef99dd8d21b45cb4d132d31e6d582d49ea5e23b905f55cb0d4a20b1ecb58de1bcbfdad1d016e536fc622b63214 mod_auth_kerb-5.4.tar.gz
-15100aee410f899fae41d921c1016bc901602871fd387834b4d486521db7ffeb6e917bfcdc5841c8cb2828497e230aa9f04071e36c31ccc8ed5ede3fb0a286dd mod_auth_kerb-5.4-httpd24.patch
+fb7c8b18adce99c1bd200a8c1dd7794d0ecee49aa6308180b03537be160ea4426150f1421be9e2462f036296fbd220aa823a2689023899c66817baea8416aad9 mod_auth_kerb-5.4-httpd24.patch
f8fd9cce15593592995a53374a7dbbf6171c4f5e9e82d5bf59953fcfa6fa81cf6890ec4c9ddc2e0963060ea34e98b590f037b1f0274c284085350e6bc4792748 mod_auth_kerb_compile.patch
b6cfa12dbfd37f98de4d5b23f16462efbfa394d4e9dd6a15772aa18fbec0704c3d9f6e5d242d501a8f1c3091abf893de261115ee54ea31d9d9e0a4d1724473a4 mod-auth-kerb.conf"
diff --git a/main/apache-mod-auth-kerb/mod_auth_kerb-5.4-httpd24.patch b/main/apache-mod-auth-kerb/mod_auth_kerb-5.4-httpd24.patch
index 4f2c0887222..673eaa8ceae 100644
--- a/main/apache-mod-auth-kerb/mod_auth_kerb-5.4-httpd24.patch
+++ b/main/apache-mod-auth-kerb/mod_auth_kerb-5.4-httpd24.patch
@@ -1,6 +1,6 @@
---- mod_auth_kerb-5.4/src/mod_auth_kerb.c.httpd24
-+++ mod_auth_kerb-5.4/src/mod_auth_kerb.c
-@@ -179,6 +179,16 @@ static apr_global_mutex_t *s4u2proxy_loc
+--- a/src/mod_auth_kerb.c
++++ b/src/mod_auth_kerb.c
+@@ -147,6 +147,16 @@
#define PROXYREQ_PROXY STD_PROXY
#endif
@@ -17,7 +17,7 @@
/***************************************************************************
Auth Configuration Structure
***************************************************************************/
-@@ -383,7 +393,11 @@ cmd_delegationlock(cmd_parms *cmd, void
+@@ -348,7 +358,11 @@
}
static void
@@ -30,7 +30,7 @@
const request_rec *r, const char *fmt, ...)
{
char errstr[1024];
-@@ -394,7 +408,9 @@ log_rerror(const char *file, int line, i
+@@ -359,7 +373,9 @@
va_end(ap);
@@ -41,7 +41,7 @@
ap_log_rerror(file, line, level | APLOG_NOERRNO, status, r, "%s", errstr);
#else
ap_log_rerror(file, line, level | APLOG_NOERRNO, r, "%s", errstr);
-@@ -1860,8 +1876,8 @@ already_succeeded(request_rec *r, char *
+@@ -1555,8 +1571,8 @@
char keyname[1024];
snprintf(keyname, sizeof(keyname) - 1,
@@ -52,7 +52,7 @@
if (apr_pool_userdata_get((void**)&conn_data, keyname, r->connection->pool) != 0)
return NULL;
-@@ -2014,7 +2030,7 @@ kerb_authenticate_user(request_rec *r)
+@@ -1709,7 +1725,7 @@
prevauth->last_return = ret;
snprintf(keyname, sizeof(keyname) - 1,
"mod_auth_kerb::connection::%s::%ld",
@@ -60,3 +60,4 @@
+ client_ip(r), r->connection->id);
apr_pool_userdata_set(prevauth, keyname, NULL, r->connection->pool);
}
+