summaryrefslogtreecommitdiff
path: root/main/aom/posix-implicit.patch
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-01-14 13:29:29 +0000
committerpsykose <alice@ayaya.dev>2023-01-14 14:29:29 +0100
commit3b734a3953df25924bbabcaf3053951402d4da3a (patch)
treec1169d36b4fef7e398e49047f7f8b6abdbb865e7 /main/aom/posix-implicit.patch
parent9d6d82de16160834387a5a9d70ae92db71af029a (diff)
downloadaports-3b734a3953df25924bbabcaf3053951402d4da3a.zip
main/aom: fix implicit function decl
Diffstat (limited to 'main/aom/posix-implicit.patch')
-rw-r--r--main/aom/posix-implicit.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/main/aom/posix-implicit.patch b/main/aom/posix-implicit.patch
new file mode 100644
index 00000000000..6e910b3f732
--- /dev/null
+++ b/main/aom/posix-implicit.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/869419
+
+POSIX_C_SOURCE is needed for ftello.
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -266,6 +266,7 @@ add_library(aom_rtcd OBJECT ${AOM_RTCD_SOURCES})
+ add_dependencies(aom_rtcd aom_version)
+
+ if(ENABLE_EXAMPLES)
++ add_definitions(-D_POSIX_C_SOURCE=200112L)
+ add_library(aom_encoder_stats OBJECT ${AOM_ENCODER_STATS_SOURCES})
+ set(AOM_LIB_TARGETS ${AOM_LIB_TARGETS} aom_encoder_stats)
+ endif()