summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-12-27 14:58:29 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-27 15:49:40 +0100
commitcaf3e7f22c332e6567e098d5ee2b4e7cfd2bf096 (patch)
tree891a58aca501e75a924985e7698734dba7665d85 /community
parent7063bf49583718a9eca72528be52055c44243190 (diff)
downloadaports-caf3e7f22c332e6567e098d5ee2b4e7cfd2bf096.zip
community/accounts-qml-module: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/accounts-qml-module/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/accounts-qml-module/APKBUILD b/community/accounts-qml-module/APKBUILD
new file mode 100644
index 00000000000..b8671581259
--- /dev/null
+++ b/community/accounts-qml-module/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=accounts-qml-module
+pkgver=0.7_git20190605
+pkgrel=0
+_commit="69e17dec5add40655cd9334ec7ad4eef13fed8a4"
+arch="all"
+url="https://gitlab.com/accounts-sso/accounts-qml-module"
+pkgdesc="QML bindings for libaccounts-qt + libsignon-qt"
+license="LGPL-2.1-only"
+makedepends="qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qttools-dev libaccounts-qt-dev signond-dev qtchooser"
+checkdepends="xvfb-run"
+#source="https://gitlab.com/accounts-sso/accounts-qml-module/-/archive/VERSION_$pkgver/accounts-qml-module-VERSION_$pkgver.tar.gz"
+source="$pkgname-$_commit.tar.gz::https://gitlab.com/accounts-sso/accounts-qml-module/-/archive/$_commit.tar.gz"
+options="!check" # Requires dbus-test-runner which isn't in the Alpine repos
+builddir="$srcdir/$pkgname-$_commit"
+
+build() {
+ qmake-qt5 \
+ PREFIX=/usr \
+ LIBDIR=/usr/lib \
+ CONFIG+=no_docs
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir" make install
+}
+
+sha512sums="fd74f6e050d82586e04af1a29e6802c83559de0201f195c122b378051fcd86ecd02f057cbf1cfb1b9e42bcbbbb697e06d74df24ee32ef84cbff1b5d688db3802 accounts-qml-module-69e17dec5add40655cd9334ec7ad4eef13fed8a4.tar.gz"