summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-12-27 15:01:20 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-27 15:49:41 +0100
commit6096977d845bde953815a962c6433ef63c20a8cd (patch)
treeb91027e3814b03c54fa648b6bfb170d156688a07 /community
parent30f0f4509f20023ce434d16b2af52194c194ca3e (diff)
downloadaports-6096977d845bde953815a962c6433ef63c20a8cd.zip
community/signond: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/signond/APKBUILD36
-rw-r--r--community/signond/busybox-incompatibility.patch14
2 files changed, 50 insertions, 0 deletions
diff --git a/community/signond/APKBUILD b/community/signond/APKBUILD
new file mode 100644
index 00000000000..acda9ea699f
--- /dev/null
+++ b/community/signond/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=signond
+pkgver=8.60
+pkgrel=0
+arch="all"
+url="https://gitlab.com/accounts-sso/signond"
+pkgdesc="A D-Bus service which performs user authentication on behalf of its clients"
+license="LGPL-2.1-only"
+makedepends="qt5-qtbase-dev doxygen graphviz"
+checkdepends="dbus-x11"
+source="https://gitlab.com/accounts-sso/signond/-/archive/VERSION_$pkgver/signond-VERSION_$pkgver.tar.gz
+ busybox-incompatibility.patch"
+subpackages="$pkgname-doc $pkgname-static $pkgname-dev"
+if [ "$CARCH" = armv7 ]; then
+ options="!check" # Broken
+fi
+builddir="$srcdir/$pkgname-VERSION_$pkgver"
+
+build() {
+ qmake-qt5 \
+ PREFIX=/usr \
+ LIBDIR=/usr/lib
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir" make install
+}
+
+sha512sums="fb3ccc99c692506ca29d5bae39bc375ff97057734fac1551ea39105d5f8e78f3df23e01a286f73be3a606c54b40f957c3c0d985484926e57f354218e4137ff3c signond-VERSION_8.60.tar.gz
+1fb27bd57d9478f17d0a53b9e9efb598bb10323f8f8887b7bda768ec11abe830c46620abffe95ed6361283522967d62457d6a120a0b28b3fe100c8dbeb5e9b9a busybox-incompatibility.patch"
diff --git a/community/signond/busybox-incompatibility.patch b/community/signond/busybox-incompatibility.patch
new file mode 100644
index 00000000000..25028a2fa34
--- /dev/null
+++ b/community/signond/busybox-incompatibility.patch
@@ -0,0 +1,14 @@
+diff --git a/tests/run-with-signond.sh b/tests/run-with-signond.sh
+index ad04b03..e6d2540 100755
+--- a/tests/run-with-signond.sh
++++ b/tests/run-with-signond.sh
+@@ -6,7 +6,8 @@ set -e
+
+ # start a local signond
+
+-export HOME="$(mktemp -d --tmpdir signond-tests-XXXXXX)"
++
++export HOME="$(mktemp -d)"
+ export SSO_LOGGING_LEVEL=2
+ export SSO_STORAGE_PATH="${HOME}"
+ export SSO_DAEMON_TIMEOUT=5