summaryrefslogtreecommitdiff
path: root/community/k9s
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2021-01-06 09:25:49 +0100
committerAndy Postnikov <apostnikov@gmail.com>2021-01-06 12:17:49 +0000
commit08ae8685926231fca8283a68f765774f86fc3661 (patch)
tree82ddb47bcd12a96a7a682366616f460a20829840 /community/k9s
parent6268bf08e7b69024af2f9b44377f0eda1beebf15 (diff)
downloadaports-08ae8685926231fca8283a68f765774f86fc3661.zip
community/k9s: move from testing
Diffstat (limited to 'community/k9s')
-rw-r--r--community/k9s/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/k9s/APKBUILD b/community/k9s/APKBUILD
new file mode 100644
index 00000000000..20e528094e6
--- /dev/null
+++ b/community/k9s/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Galen Abell <galen@galenabell.com>
+# Maintainer: Galen Abell <galen@galenabell.com>
+pkgname=k9s
+_pkgname=github.com/derailed/k9s
+pkgver=0.24.2
+pkgrel=0
+_commit=a952806e # git rev-parse --short HEAD
+_date=2020-11-16T17:25:46UTC # date -u -d @$(date +%s) +%FT%T%Z
+pkgdesc="Kubernetes TUI"
+url="https://k9scli.io"
+arch="all !x86 !armhf !mips64" # tests fail on x86 and arm7 for some reason, missing go on mips
+license="Apache-2.0"
+makedepends="go"
+options="net chmod-clean"
+source="$pkgname-$pkgver.tar.gz::https://github.com/derailed/k9s/archive/v$pkgver.tar.gz"
+
+export GOPATH="$srcdir/go"
+export GOCACHE="$srcdir/go-build"
+export GOTMPDIR="$srcdir"
+
+build() {
+ local ldflags="-w -s -X $_pkgname/cmd.version=$pkgver -X $_pkgname/cmd.commit=$_commit -X $_pkgname/cmd.date=$_date"
+ go build -ldflags "$ldflags" -a -tags netgo -o execs/$pkgname main.go
+}
+
+check() {
+ go test ./...
+}
+
+package() {
+ install -Dm755 execs/$pkgname "$pkgdir"/usr/bin/$pkgname
+}
+
+sha512sums="437f2074c19081083bf0890a1f18afe8f5cde9ba6ac23ef46fc855de490e5c659f6081406be6d7a257d5c83eac34b3941353d81bde34db2d45a6f4fa25bc50f6 k9s-0.24.2.tar.gz"