summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrassy Boykinov <kboykinov@teamcentrixx.com>2024-02-08 12:10:52 +0100
committerPatrycja Rosa <alpine@ptrcnull.me>2024-02-11 22:58:20 +0000
commitfbaec483ee15c04fcec39e3e149043c640c76d2c (patch)
treebbd10194e7bf8e2208eeb562d7e9d95584754476
parente2d450ea0a313b5128fca4c1ff1eef99b31e8b9e (diff)
downloadaports-fbaec483ee15c04fcec39e3e149043c640c76d2c.zip
main/efivar: upgrade to 39
-rw-r--r--main/efivar/APKBUILD16
-rw-r--r--main/efivar/fix-build-riscv64.patch12
-rw-r--r--main/efivar/lfs64.patch46
-rw-r--r--main/efivar/musl-compat.patch231
-rw-r--r--main/efivar/ppc64le-compat.patch22
5 files changed, 10 insertions, 317 deletions
diff --git a/main/efivar/APKBUILD b/main/efivar/APKBUILD
index 3f4d9235258..c2a422500eb 100644
--- a/main/efivar/APKBUILD
+++ b/main/efivar/APKBUILD
@@ -1,19 +1,16 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Lucas Ramage <ramage.lucas@protonmail.com>
pkgname=efivar
-pkgver=38
-pkgrel=4
+pkgver=39
+pkgrel=0
pkgdesc="Tools and library to manipulate EFI variables"
url="https://github.com/rhboot/efivar"
arch="all !s390x"
license="LGPL-2.1-only"
makedepends="popt-dev linux-headers mandoc"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="https://github.com/rhboot/efivar/releases/download/$pkgver/efivar-$pkgver.tar.bz2
- lfs64.patch
- musl-compat.patch
+source="$pkgname-$pkgver.tar.gz::https://github.com/rhboot/efivar/archive/refs/tags/$pkgver.tar.gz
ppc64le-compat.patch
- fix-build-riscv64.patch
"
prepare() {
@@ -35,9 +32,6 @@ check() {
}
sha512sums="
-c2f17297c863ece134a9dd758d237fd2df8c8d072f87af1d0bf2bcf9acfc7a53c25597f03fd4fb8cc664b205743d4ffa0ef1b068d0f73c58fa573d40993f3155 efivar-38.tar.bz2
-b267ed990e1d89209dc9d1b875d186def8ba58c404e22bee6fdc91fd469c4673fda8605b52af1cdadf361b530c1e81c3f8d5f1374ad6f647dfee1bb0a9e0a4ba lfs64.patch
-1a1dfd66a5b613167eeedafe3f2728a0e644cb89860c3dad5955cbaba254ecde617e05d969eeac50be443d090136cbfec626f878f49eea2458b6b8ca17287bd4 musl-compat.patch
-77e04d2df6797faef478bde4f591dc728a90ad27a55f4a26bb3b0f427a2dd31de0b97272a176e79880125fdc2cdd1eff184c9c80c4fedb40c4304f633691d13b ppc64le-compat.patch
-042dfb79b05032cbc9baad94a9ebf7e61e1bc5976e728287f96b426229a28e1c8dea2392ed262b2753ecac1b5146d6814cb2ecf44fdfa1e63e8e968c521f33ec fix-build-riscv64.patch
+04493c30efbfc2773abac9a3dd93aa13403c05e29e3bfc72877d2054930811fae99119aadcb1729b6ca85abf5a24db786ea0c27c16d5458ef1b19e74696f5ff7 efivar-39.tar.gz
+6a1210b51c647fe6b24d05e1e39518531c3ec2cdd781f0627ec878ec11515949c38021c27e8f8b0138e53e9aafb5a4b266b7b8588d5bcdfd57f45d6316d4ccb0 ppc64le-compat.patch
"
diff --git a/main/efivar/fix-build-riscv64.patch b/main/efivar/fix-build-riscv64.patch
deleted file mode 100644
index d433a9f9ee6..00000000000
--- a/main/efivar/fix-build-riscv64.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/src/include/defaults.mk 2022-05-30 17:18:56.805985253 +0000
-+++ b/src/include/defaults.mk 2022-05-30 17:18:16.272463577 +0000
-@@ -81,6 +81,9 @@
- else
- HOST_MARCH=
- endif
-+ifeq ($(HOST_ARCH),riscv64)
-+ HOST_MARCH=
-+endif
- HOST_CPPFLAGS ?= $(CPPFLAGS)
- override _HOST_CPPFLAGS := $(HOST_CPPFLAGS)
- override HOST_CPPFLAGS = $(_HOST_CPPFLAGS) \
diff --git a/main/efivar/lfs64.patch b/main/efivar/lfs64.patch
deleted file mode 100644
index b84e91aa391..00000000000
--- a/main/efivar/lfs64.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-Patch-Source: https://github.com/rhboot/efivar/commit/914c686cc54b2405dab08bff77cd60827aab54b1
---
-From 914c686cc54b2405dab08bff77cd60827aab54b1 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Wed, 14 Dec 2022 16:55:51 -0800
-Subject: [PATCH] Use off_t instead of off64_t
-
-Pass _FILE_OFFSET_BITS=64 to ensure 64bit off_t
-
-This helps building efivar for 32bit arches on systems using musl C
-library. It works with glibc since _GNU_SOURCE defines
-_LARGEFILE64_SOURCE as well, this feature test macro enables the 64bit
-interfaces which were done as intermediate steps when transition to
-66-bit off_t was done as part olf LFS64 support.
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/error.c | 2 +-
- src/include/defaults.mk | 1 +
- 2 files changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/src/error.c b/src/error.c
-index fcbba0d6..9530e22c 100644
---- a/src/error.c
-+++ b/src/error.c
-@@ -191,7 +191,7 @@ dbglog_write(void *cookie, const char *buf, size_t size)
- }
-
- static int
--dbglog_seek(void *cookie UNUSED, off64_t *offset, int whence)
-+dbglog_seek(void *cookie UNUSED, off_t *offset, int whence)
- {
- FILE *log = efi_errlog ? efi_errlog : stderr;
- int rc;
-diff --git a/src/include/defaults.mk b/src/include/defaults.mk
-index 42bd3d6e..bb9c997f 100644
---- a/src/include/defaults.mk
-+++ b/src/include/defaults.mk
-@@ -34,6 +34,7 @@ CPPFLAGS ?=
- override _CPPFLAGS := $(CPPFLAGS)
- override CPPFLAGS = $(_CPPFLAGS) -DLIBEFIVAR_VERSION=$(VERSION) \
- -D_GNU_SOURCE \
-+ -D_FILE_OFFSET_BITS=64 \
- -I$(TOPDIR)/src/include/
- CFLAGS ?= $(OPTIMIZE) $(DEBUGINFO) $(WARNINGS) $(ERRORS)
- CFLAGS_GCC ?= -specs=$(TOPDIR)/src/include/gcc.specs \
diff --git a/main/efivar/musl-compat.patch b/main/efivar/musl-compat.patch
deleted file mode 100644
index 00229be5c72..00000000000
--- a/main/efivar/musl-compat.patch
+++ /dev/null
@@ -1,231 +0,0 @@
-From cece3ffd5be2f8641eb694513f2b73e5eb97ffd3 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Fri, 28 Jan 2022 12:13:30 +0100
-Subject: [PATCH 1/2] efisecdb: fix build with musl libc
-
-Refactor code to use POSIX atexit(3) instead of the GNU specific
-on_exit(3).
-
-Resolves: #197
-Resolves: #202
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- src/compiler.h | 2 --
- src/efisecdb.c | 68 +++++++++++++++++++-------------------------------
- 2 files changed, 26 insertions(+), 44 deletions(-)
-
-diff --git a/src/compiler.h b/src/compiler.h
-index e2f18f0b..d95fb014 100644
---- a/src/compiler.h
-+++ b/src/compiler.h
-@@ -7,8 +7,6 @@
- #ifndef COMPILER_H_
- #define COMPILER_H_
-
--#include <sys/cdefs.h>
--
- /* GCC version checking borrowed from glibc. */
- #if defined(__GNUC__) && defined(__GNUC_MINOR__)
- # define GNUC_PREREQ(maj,min) \
-diff --git a/src/efisecdb.c b/src/efisecdb.c
-index f8823737..6bd5ad90 100644
---- a/src/efisecdb.c
-+++ b/src/efisecdb.c
-@@ -25,6 +25,10 @@
- extern char *optarg;
- extern int optind, opterr, optopt;
-
-+static efi_secdb_t *secdb = NULL;
-+static list_t infiles;
-+static list_t actions;
-+
- struct hash_param {
- char *name;
- efi_secdb_type_t algorithm;
-@@ -187,12 +191,11 @@ add_action(list_t *list, action_type_t action_type, const efi_guid_t *owner,
- }
-
- static void
--free_actions(int status UNUSED, void *actionsp)
-+free_actions(void)
- {
-- list_t *actions = (list_t *)actionsp;
- list_t *pos, *tmp;
-
-- for_each_action_safe(pos, tmp, actions) {
-+ for_each_action_safe(pos, tmp, &actions) {
- action_t *action = list_entry(pos, action_t, list);
-
- list_del(&action->list);
-@@ -202,12 +205,11 @@ free_actions(int status UNUSED, void *actionsp)
- }
-
- static void
--free_infiles(int status UNUSED, void *infilesp)
-+free_infiles(void)
- {
-- list_t *infiles = (list_t *)infilesp;
- list_t *pos, *tmp;
-
-- for_each_ptr_safe(pos, tmp, infiles) {
-+ for_each_ptr_safe(pos, tmp, &infiles) {
- ptrlist_t *entry = list_entry(pos, ptrlist_t, list);
-
- list_del(&entry->list);
-@@ -216,27 +218,12 @@ free_infiles(int status UNUSED, void *infilesp)
- }
-
- static void
--maybe_free_secdb(int status UNUSED, void *voidp)
-+maybe_free_secdb(void)
- {
-- efi_secdb_t **secdbp = (efi_secdb_t **)voidp;
--
-- if (secdbp == NULL || *secdbp == NULL)
-+ if (secdb == NULL)
- return;
-
-- efi_secdb_free(*secdbp);
--}
--
--static void
--maybe_do_unlink(int status, void *filep)
--{
-- char **file = (char **)filep;
--
-- if (status == 0)
-- return;
-- if (file == NULL || *file == NULL)
-- return;
--
-- unlink(*file);
-+ efi_secdb_free(secdb);
- }
-
- static void
-@@ -323,15 +310,6 @@ parse_input_files(list_t *infiles, char **outfile, efi_secdb_t **secdb,
- return status;
- }
-
--/*
-- * These need to be static globals so that they're not on main's stack when
-- * on_exit() fires.
-- */
--static efi_secdb_t *secdb = NULL;
--static list_t infiles;
--static list_t actions;
--static char *outfile = NULL;
--
- int
- main(int argc, char *argv[])
- {
-@@ -351,6 +329,7 @@ main(int argc, char *argv[])
- bool do_sort_data = false;
- bool sort_descending = false;
- int status = 0;
-+ char *outfile = NULL;
-
- const char sopts[] = ":aAc:dfg:h:i:Lo:rs:t:v?";
- const struct option lopts[] = {
-@@ -376,10 +355,9 @@ main(int argc, char *argv[])
- INIT_LIST_HEAD(&infiles);
- INIT_LIST_HEAD(&actions);
-
-- on_exit(free_actions, &actions);
-- on_exit(free_infiles, &infiles);
-- on_exit(maybe_free_secdb, &secdb);
-- on_exit(maybe_do_unlink, &outfile);
-+ atexit(free_actions);
-+ atexit(free_infiles);
-+ atexit(maybe_free_secdb);
-
- /*
- * parse the command line.
-@@ -587,24 +565,30 @@ main(int argc, char *argv[])
- outfd = open(outfile, flags, 0600);
- if (outfd < 0) {
- char *tmpoutfile = outfile;
-- if (errno == EEXIST)
-- outfile = NULL;
-+ if (errno != EEXIST)
-+ unlink(outfile);
- err(1, "could not open \"%s\"", tmpoutfile);
- }
-
- rc = ftruncate(outfd, 0);
-- if (rc < 0)
-+ if (rc < 0) {
-+ unlink(outfile);
- err(1, "could not truncate output file \"%s\"", outfile);
-+ }
-
- void *output;
- size_t size = 0;
- rc = efi_secdb_realize(secdb, &output, &size);
-- if (rc < 0)
-+ if (rc < 0) {
-+ unlink(outfile);
- secdb_err(1, "could not realize signature list");
-+ }
-
- rc = write(outfd, output, size);
-- if (rc < 0)
-+ if (rc < 0) {
-+ unlink(outfile);
- err(1, "could not write signature list");
-+ }
-
- close(outfd);
- xfree(output);
-
-From df09b472419466987f2f30176dd00937e640aa9a Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Fri, 28 Jan 2022 12:29:00 +0100
-Subject: [PATCH 2/2] efisecdb: do not free optarg
-
-The *outfile passed to parse_input_files can only be either set to
-optarg or be NULL. optarg should not be free'd and NULL does not need
-to.
-
-Since we no longer use on_exit to unlink outfile we also don't need to
-set *outfile to NULL.
-
-Fixes commit d91787035bc1 (efisecdb: add efisecdb)
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- src/efisecdb.c | 7 ++-----
- 1 file changed, 2 insertions(+), 5 deletions(-)
-
-diff --git a/src/efisecdb.c b/src/efisecdb.c
-index 6bd5ad90..70fa1847 100644
---- a/src/efisecdb.c
-+++ b/src/efisecdb.c
-@@ -255,8 +255,7 @@ list_guids(void)
- * failure.
- */
- static int
--parse_input_files(list_t *infiles, char **outfile, efi_secdb_t **secdb,
-- bool dump)
-+parse_input_files(list_t *infiles, efi_secdb_t **secdb, bool dump)
- {
- int status = 0;
- list_t *pos, *tmp;
-@@ -297,8 +296,6 @@ parse_input_files(list_t *infiles, char **outfile, efi_secdb_t **secdb,
- if (!dump)
- exit(1);
- status = 1;
-- xfree(*outfile);
-- *outfile = NULL;
- break;
- }
- }
-@@ -528,7 +525,7 @@ main(int argc, char *argv[])
- efi_secdb_set_bool(secdb, EFI_SECDB_SORT_DATA, do_sort_data);
- efi_secdb_set_bool(secdb, EFI_SECDB_SORT_DESCENDING, sort_descending);
-
-- status = parse_input_files(&infiles, &outfile, &secdb, dump);
-+ status = parse_input_files(&infiles, &secdb, dump);
- if (status == 0) {
- for_each_action_safe(pos, tmp, &actions) {
- action_t *action = list_entry(pos, action_t, list);
diff --git a/main/efivar/ppc64le-compat.patch b/main/efivar/ppc64le-compat.patch
index 5116d88f280..85660a4d01d 100644
--- a/main/efivar/ppc64le-compat.patch
+++ b/main/efivar/ppc64le-compat.patch
@@ -1,26 +1,17 @@
-From 625e24ca91a258ce0cc32a9bb3a67358414254b2 Mon Sep 17 00:00:00 2001
-From: Lucas Ramage <lucas.ramage@infinite-omicron.com>
-Date: Sun, 24 Apr 2022 16:07:36 -0400
-Subject: [PATCH 1/1] Fix the -march=native issue for ppc64le
-
-Resolves #213
-
-Signed-off-by: Lucas Ramage <lucas.ramage@infinite-omicron.com>
----
- src/include/defaults.mk | 4 ++++
- 1 file changed, 4 insertions(+)
-
diff --git a/src/include/defaults.mk b/src/include/defaults.mk
-index 632b155..d756caa 100644
+index 4da0cde..ccfadf2 100644
--- a/src/include/defaults.mk
+++ b/src/include/defaults.mk
-@@ -73,10 +73,14 @@ override SOFLAGS = $(_SOFLAGS) \
+@@ -73,6 +73,7 @@ override SOFLAGS = $(_SOFLAGS) \
HOST_ARCH=$(shell uname -m)
ifneq ($(HOST_ARCH),ia64)
+ifneq ($(HOST_ARCH),ppc64le)
+ ifneq ($(HOST_ARCH),riscv64)
HOST_MARCH=-march=native
else
+@@ -81,6 +82,9 @@ endif
+ else
HOST_MARCH=
endif
+else
@@ -29,6 +20,3 @@ index 632b155..d756caa 100644
HOST_CPPFLAGS ?= $(CPPFLAGS)
override _HOST_CPPFLAGS := $(HOST_CPPFLAGS)
override HOST_CPPFLAGS = $(_HOST_CPPFLAGS) \
---
-2.32.0
-