summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoromni <omni+alpine@hack.org>2023-10-27 13:33:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2023-10-30 10:26:21 +0000
commitdd5f243fcf04251e3abb610ebe1447d6bf9b3199 (patch)
tree5f67b7a0c8c8b98ce9bbcf7b9f25e0492e16364b
parent74a594420210b9355370cf14f3cf104b2a9c14d5 (diff)
downloadaports-dd5f243fcf04251e3abb610ebe1447d6bf9b3199.zip
main/py3-ply: switch to gpep517
-rw-r--r--main/py3-ply/APKBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/main/py3-ply/APKBUILD b/main/py3-ply/APKBUILD
index d3db083f7f9..35e057966a1 100644
--- a/main/py3-ply/APKBUILD
+++ b/main/py3-ply/APKBUILD
@@ -4,32 +4,34 @@
_pkgname=ply
pkgname=py3-$_pkgname
pkgver=3.11
-pkgrel=9
+pkgrel=10
pkgdesc="Python Lex & Yacc"
url="https://www.dabeaz.com/ply/"
arch="noarch"
license="BSD-3-Clause"
depends="python3"
-makedepends="python3-dev"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
subpackages="$pkgname-pyc"
-source="$_pkgname-$pkgver.tar.gz::https://github.com/dabeaz/$_pkgname/archive/$pkgver.tar.gz
+source="$_pkgname-$pkgver.tar.gz::https://github.com/dabeaz/ply/archive/$pkgver.tar.gz
no-py3-six.patch
"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel --wheel-dir .dist --output-fd 3 3>&1 >&2
}
check() {
- PYTHON=python3 make test
-
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
cd test
- python3 testcpp.py
+ ../.testenv/bin/python3 testlex.py
+ ../.testenv/bin/python3 testyacc.py
+ ../.testenv/bin/python3 testcpp.py
}
package() {
- python3 setup.py install --skip-build --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
sha512sums="