summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2023-09-13 05:19:56 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2023-09-13 10:24:22 +0000
commitd9ccfc30b07e9e859310af1d25673e56c0df3e64 (patch)
treeb67349028a2eb0cad8dd1eab54f60b40dc2645de
parent161951202445d2c71563f5ea015a7bcb62a6b937 (diff)
downloadaports-d9ccfc30b07e9e859310af1d25673e56c0df3e64.zip
main/jq: use upstream provided source
Instead of the github generated source archives, use the archives provided by upstream. This contains the autotools scripts already and also a version.h file which is required to show the version from `jq --version`. Fixes #15261
-rw-r--r--main/jq/APKBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/main/jq/APKBUILD b/main/jq/APKBUILD
index 5c7e400d9fc..821fb9fe383 100644
--- a/main/jq/APKBUILD
+++ b/main/jq/APKBUILD
@@ -2,25 +2,19 @@
# Maintainer: Johannes Matheis <jomat+alpinebuild@jmt.gr>
pkgname=jq
pkgver=1.7
-pkgrel=0
+pkgrel=1
pkgdesc="A lightweight and flexible command-line JSON processor"
url="https://jqlang.github.io/jq/"
arch="all"
license="MIT"
-makedepends="oniguruma-dev automake autoconf libtool"
+makedepends="oniguruma-dev"
subpackages="$pkgname-doc $pkgname-dev"
-source="https://github.com/jqlang/jq/archive/refs/tags/jq-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgname-$pkgver"
+source="jq-$pkgver.tar.gz::https://github.com/jqlang/jq/releases/download/jq-1.7/jq-1.7.tar.gz"
# secfixes:
# 1.6_rc1-r0:
# - CVE-2016-4074
-prepare() {
- default_prepare
- autoreconf -fi
-}
-
build() {
./configure \
--build=$CBUILD \
@@ -42,5 +36,5 @@ package() {
}
sha512sums="
-01676319fe98d5ab1e278430b2c58ec594191cc9485a20312d658c0e199ac7ea5f5e934817ce98da0864ec7e0a018aae9b87525260e8ab6a7bde918db483bd84 jq-1.7.tar.gz
+4f8a6b0401e6c881dcb97d948fe38871062599a43fff667ede21cf185ec9de33e61878f0a6ea12786d0a632eea592ea0ff860520ba02dbb32f2fa2d2b5db7a0a jq-1.7.tar.gz
"