summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2022-09-21 14:20:18 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2022-09-23 15:28:27 +0200
commitd583419b187bd1a002ecdbcd44ec8c054f4dc30b (patch)
tree0982e72a02c0f151cbf1bdb50fc0b3fbde474a48
parent26b069ab048624c89a88f71333dcd06f5de813a4 (diff)
downloadaports-d583419b187bd1a002ecdbcd44ec8c054f4dc30b.zip
main/ldb: upgrade to 2.5.2
-rw-r--r--main/ldb/APKBUILD24
-rw-r--r--main/ldb/strtoull.patch89
2 files changed, 100 insertions, 13 deletions
diff --git a/main/ldb/APKBUILD b/main/ldb/APKBUILD
index e713d91ba3d..2c3b7d9029b 100644
--- a/main/ldb/APKBUILD
+++ b/main/ldb/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ldb
-pkgver=2.4.4
+pkgver=2.5.2
pkgrel=0
pkgdesc="schema-less, ldap like, API and database"
url="https://ldb.samba.org/"
@@ -11,6 +11,7 @@ makedepends="libtirpc-dev tevent-dev py3-tevent tdb-dev py3-tdb talloc-dev
subpackages="$pkgname-dev py3-$pkgname:_py3 $pkgname-tools $pkgname-doc"
source="https://www.samba.org/ftp/pub/ldb/ldb-$pkgver.tar.gz
disable-compile-error-test.patch
+ strtoull.patch
"
# secfixes:
@@ -25,40 +26,37 @@ case "$CARCH" in
esac
build() {
- "$_waf" configure \
+ ./configure \
--prefix=/usr \
--disable-rpath \
--disable-rpath-install \
--builtin-libraries=replace \
--bundled-libraries=NONE \
--with-modulesdir=/usr/lib/ldb/modules
- "$_waf" build
+ make
}
check() {
- "$_waf" test
+ make check
}
package() {
- DESTDIR="$pkgdir" "$_waf" install
+ make install DESTDIR="$pkgdir"
}
_py3() {
pkgdesc="Python 3 binding for the ldb library"
-
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/python3* "$subpkgdir"/usr/lib/
- mv "$pkgdir"/usr/lib/libpyldb-util.cpython* "$subpkgdir"/usr/lib/
+ amove usr/lib/python3* \
+ usr/lib/libpyldb-util.cpython*
}
tools() {
pkgdesc="Tools to manage LDB files"
- mkdir -p "$subpkgdir"/usr/lib/ldb
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
- mv "$pkgdir"/usr/lib/ldb/libldb-cmdline.* "$subpkgdir"/usr/lib/ldb/
+ amove usr/bin usr/lib/ldb/libldb-cmdline.*
}
sha512sums="
-2e4c762525eee9db40083b21e2a23f9cdfad5d2969cc628b3ea5414f9ec1be2c12d0aa65137cd8d8a5395c0414166ba14fc3dd57d53c533596762d80b9c561f4 ldb-2.4.4.tar.gz
+02ae1246f99d9b6d6b33c5030488aa46c6abb535b4da4b13799a62b49d32c490b7c088ef41c0bc5a1b2f7263c680faceb8033827834cb6f66916adcdb5be421c ldb-2.5.2.tar.gz
ed55d5151bbcaf5c0a1b70a1f44b461a501ad94ce02ee97e3ea10c560ce3656a190510697bbd3c5b6f70a74519bf7c0a91210bcb415ffd97d9440045e10a02e8 disable-compile-error-test.patch
+8e005bf69759b962b60898a746443a7324ab93dde0e6e21bbeddeb6e49a9cb90152129ef874c8cf82c45291427363307182bb54ce573eee3669ec0f0a251e3cb strtoull.patch
"
diff --git a/main/ldb/strtoull.patch b/main/ldb/strtoull.patch
new file mode 100644
index 00000000000..2fcd928a3d1
--- /dev/null
+++ b/main/ldb/strtoull.patch
@@ -0,0 +1,89 @@
+diff --git a/lib/replace/replace.c b/lib/replace/replace.c
+index 0652cb4..02b6ebf 100644
+--- a/lib/replace/replace.c
++++ b/lib/replace/replace.c
+@@ -559,41 +559,6 @@ long long int rep_strtoll(const char *str, char **endptr, int base)
+ #endif /* HAVE_STRTOLL */
+
+
+-#ifndef HAVE_STRTOULL
+-unsigned long long int rep_strtoull(const char *str, char **endptr, int base)
+-{
+-#ifdef HAVE_STRTOUQ
+- return strtouq(str, endptr, base);
+-#elif defined(HAVE___STRTOULL)
+- return __strtoull(str, endptr, base);
+-#elif SIZEOF_LONG == SIZEOF_LONG_LONG
+- return (unsigned long long int) strtoul(str, endptr, base);
+-#else
+-# error "You need a strtoull function"
+-#endif
+-}
+-#else
+-#ifdef HAVE_BSD_STRTOLL
+-#undef strtoull
+-unsigned long long int rep_strtoull(const char *str, char **endptr, int base)
+-{
+- int saved_errno = errno;
+- unsigned long long int nb = strtoull(str, endptr, base);
+- /* With glibc EINVAL is only returned if base is not ok */
+- if (errno == EINVAL) {
+- if (base == 0 || (base >1 && base <37)) {
+- /* Base was ok so it's because we were not
+- * able to make the conversion.
+- * Let's reset errno.
+- */
+- errno = saved_errno;
+- }
+- }
+- return nb;
+-}
+-#endif /* HAVE_BSD_STRTOLL */
+-#endif /* HAVE_STRTOULL */
+-
+ #ifndef HAVE_SETENV
+ int rep_setenv(const char *name, const char *value, int overwrite)
+ {
+diff --git a/lib/replace/replace.h b/lib/replace/replace.h
+index a8910e2..854b1a7 100644
+--- a/lib/replace/replace.h
++++ b/lib/replace/replace.h
+@@ -394,16 +394,6 @@ long long int rep_strtoll(const char *str, char **endptr, int base);
+ #endif
+ #endif
+
+-#ifndef HAVE_STRTOULL
+-#define strtoull rep_strtoull
+-unsigned long long int rep_strtoull(const char *str, char **endptr, int base);
+-#else
+-#ifdef HAVE_BSD_STRTOLL /* yes, it's not HAVE_BSD_STRTOULL */
+-#define strtoull rep_strtoull
+-unsigned long long int rep_strtoull(const char *str, char **endptr, int base);
+-#endif
+-#endif
+-
+ #ifndef HAVE_FTRUNCATE
+ #define ftruncate rep_ftruncate
+ int rep_ftruncate(int,off_t);
+diff --git a/lib/replace/wscript b/lib/replace/wscript
+index 4c774d9..a1dc6d0 100644
+--- a/lib/replace/wscript
++++ b/lib/replace/wscript
+@@ -411,7 +411,7 @@ def configure(conf):
+ conf.CHECK_FUNCS('initgroups pread pwrite strndup strcasestr strsep')
+ conf.CHECK_FUNCS('strtok_r mkdtemp dup2 dprintf vdprintf isatty chown lchown')
+ conf.CHECK_FUNCS('link readlink symlink realpath snprintf vsnprintf')
+- conf.CHECK_FUNCS('asprintf vasprintf setenv unsetenv strnlen strtoull __strtoull')
++ conf.CHECK_FUNCS('asprintf vasprintf setenv unsetenv strnlen')
+ conf.CHECK_FUNCS('strtouq strtoll __strtoll strtoq memalign posix_memalign')
+ conf.CHECK_FUNCS('fmemopen')
+
+@@ -866,7 +866,7 @@ REPLACEMENT_FUNCTIONS = {
+ 'memmove', 'strdup', 'setlinebuf', 'vsyslog', 'strnlen',
+ 'strndup', 'waitpid', 'seteuid', 'setegid', 'chroot',
+ 'mkstemp', 'mkdtemp', 'pread', 'pwrite', 'strcasestr',
+- 'strsep', 'strtok_r', 'strtoll', 'strtoull', 'setenv', 'unsetenv',
++ 'strsep', 'strtok_r', 'strtoll', 'setenv', 'unsetenv',
+ 'utime', 'utimes', 'dup2', 'chown', 'link', 'readlink',
+ 'symlink', 'lchown', 'realpath', 'memmem', 'vdprintf',
+ 'dprintf', 'get_current_dir_name', 'copy_file_range',