summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2023-12-03 18:08:08 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2023-12-05 19:12:51 +0000
commitacd4a663f9d07c16adfa6b3b7a208e5ef6ad17e7 (patch)
tree224adf20f4614d93b29160c5214e2c034867ec04
parenta868f4e460d9c9b07e816974ad4d2ce8cdc2347a (diff)
downloadaports-acd4a663f9d07c16adfa6b3b7a208e5ef6ad17e7.zip
main/gdb: upgrade to 14.1
Building GDB requires GMP 4.2+, and MPFR 3.1.0+.
-rw-r--r--main/gdb/APKBUILD9
-rw-r--r--main/gdb/fix-segfault-dereferencing-the_bfd_section.patch27
2 files changed, 4 insertions, 32 deletions
diff --git a/main/gdb/APKBUILD b/main/gdb/APKBUILD
index 0c2618745cb..d4a6cd1e12e 100644
--- a/main/gdb/APKBUILD
+++ b/main/gdb/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gdb
-pkgver=13.2
-pkgrel=3
+pkgver=14.1
+pkgrel=0
pkgdesc="The GNU Debugger"
url="https://www.gnu.org/software/gdb/"
arch="all"
@@ -13,6 +13,7 @@ makedepends="
gmp-dev
libtool
linux-headers
+ mpfr-dev
ncurses-dev
perl
python3-dev
@@ -29,7 +30,6 @@ source="https://ftp.gnu.org/gnu/gdb/gdb-$pkgver.tar.xz
ppc-musl.patch
ppc-ptregs.patch
musl-signals.patch
- fix-segfault-dereferencing-the_bfd_section.patch
"
prepare() {
@@ -113,11 +113,10 @@ multiarch() {
}
sha512sums="
-8185d3e11ab60dafff5860a5016577bfe7dd7547ef01ebc867bc247603d82b74ff74c4f29492c7d2aee57076f52be33e289f4c6b414a4b870d4b3004909f4c34 gdb-13.2.tar.xz
+575e198105076fc4a88f68591aa114ab9c1196e84386a3f7b9b58fe5f30cdeed33f6a5f957b68f08c47284ec922bb60c964627e238471419673fd913575ce427 gdb-14.1.tar.xz
68f893e72742eac7e41fd7c3e688b8cccc79327f0422b03319302a1a9d24513e77d698bc6ff16f67236b521df321b9ff0ca2ee342c11f12933c492c5c530ec9b gcore-sh.patch
70e7d04e4d72461436da503b5bfa370c5779e03245c521f30e9779d5ff37dbb2d708b05f2afb27f43ad9defc44df4bd979d72f777e744851fdbf156295e1cc9f s390x-use-elf-gdb_fpregset_t.patch
04911f87904b62dd7662435f9182b20485afb29ddb3d6398a9d31fef13495f7b70639c77fdae3a40e2775e270d7cd40d0cfd7ddf832372b506808d33c8301e01 ppc-musl.patch
ab554899bbb2aa98261fd1b6beb4a71ed7c713a714bddd3fa7ec875258e39bd5474dc96a11accb4dadd316f3834f215e8395d3b373bf3affd122dc5b4a8fe710 ppc-ptregs.patch
58aacc7cdc119eab729a3c5a5521f6a0db41c6a5bc2d09d6e32cbdd071d85dd1a31b5e6559616f8da1237c5b79ad9e04aab485211e957b4d1ca752c0c5ad660b musl-signals.patch
-f32dadecea9d9525d9a88e923ff292b80fdc5122a9fdeafc2282f636eb46c18267700a0662506b2b7e2b5177a695fc62999fab8623d655d6bf352311a4643a6f fix-segfault-dereferencing-the_bfd_section.patch
"
diff --git a/main/gdb/fix-segfault-dereferencing-the_bfd_section.patch b/main/gdb/fix-segfault-dereferencing-the_bfd_section.patch
deleted file mode 100644
index 17d9ad52192..00000000000
--- a/main/gdb/fix-segfault-dereferencing-the_bfd_section.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-A user supplied an executable and a remote logfile that could be used
-to crash gdb. The problem is that the BFD section for a particular
-symbol was null, because the section was not marked "allocated".
-Digging deeper, the problem was that elfread.c dropped the section for
-absolute symbols. This patch fixes the crash.
-
-Bug: https://sourceware.org/bugzilla/show_bug.cgi?id=30431
----
- gdb/elfread.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/gdb/elfread.c b/gdb/elfread.c
-index 799e3b914f8..7697106e9b6 100644
---- a/gdb/elfread.c
-+++ b/gdb/elfread.c
-@@ -216,7 +216,8 @@ record_minimal_symbol (minimal_symbol_reader &reader,
- ELF is malformed then this might not be the case. In that case don't
- create an msymbol that references an uninitialised section object. */
- int section_index = 0;
-- if ((bfd_section_flags (bfd_section) & SEC_ALLOC) == SEC_ALLOC)
-+ if ((bfd_section_flags (bfd_section) & SEC_ALLOC) == SEC_ALLOC
-+ || bfd_section == bfd_abs_section_ptr)
- section_index = gdb_bfd_section_index (objfile->obfd.get (), bfd_section);
-
- struct minimal_symbol *result
---
-2.39.2