summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-04-10 16:55:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2024-04-12 19:06:44 +0000
commita2cfb67eecea2da96efe8f65c6a5a56e908d7f69 (patch)
tree39b4667c7c23e20f15a7a7aad0d4890e1b479011
parent982709a76bcdc3f6ce84f52b9b8c663be5941c29 (diff)
downloadaports-a2cfb67eecea2da96efe8f65c6a5a56e908d7f69.zip
testing/mediastreamer2: upgrade to 5.3.38
-rw-r--r--testing/mediastreamer2/APKBUILD24
-rw-r--r--testing/mediastreamer2/fix-cmake-path.patch14
-rw-r--r--testing/mediastreamer2/fix-soname.patch12
-rw-r--r--testing/mediastreamer2/missing-def-o-binary.patch16
4 files changed, 35 insertions, 31 deletions
diff --git a/testing/mediastreamer2/APKBUILD b/testing/mediastreamer2/APKBUILD
index a18ad922dc7..1cef0f71238 100644
--- a/testing/mediastreamer2/APKBUILD
+++ b/testing/mediastreamer2/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=mediastreamer2
-pkgver=5.2.86
-pkgrel=1
+pkgver=5.3.38
+pkgrel=0
pkgdesc="library written in C that allows you to create and run audio and video streams"
url="https://www.linphone.org/technical-corner/mediastreamer2"
arch="all"
@@ -42,7 +42,9 @@ makedepends="
"
subpackages="$pkgname-dev $pkgname-doc"
source="https://gitlab.linphone.org/BC/public/mediastreamer2/-/archive/$pkgver/mediastreamer2-$pkgver.tar.gz
- missing-def-o-binary.patch"
+ fix-cmake-path.patch
+ fix-soname.patch
+ "
build() {
cmake -G Ninja -B build \
@@ -60,7 +62,7 @@ build() {
-DENABLE_FFMPEG=YES \
-DENABLE_SPEEX_CODEC=YES \
-DENABLE_SPEEX_DSP=YES \
- -DENABLE_SHARED=YES \
+ -DBUILD_SHARED_LIBS=YES \
-DENABLE_VPX=YES \
-DENABLE_UNIT_TESTS=NO
cmake --build build
@@ -71,16 +73,8 @@ package() {
rm -r "$pkgdir"/usr/include/OpenGL
}
-dev() {
- default_dev
- mkdir -p "$subpkgdir"/usr/lib/cmake/Mediastreamer2
- mv "$pkgdir"/usr/share/Mediastreamer2/cmake/* "$subpkgdir"/usr/lib/cmake/Mediastreamer2
- # Remove empty dirs
- rmdir "$pkgdir"/usr/share/Mediastreamer2/cmake
- rmdir "$pkgdir"/usr/share/Mediastreamer2
-}
-
sha512sums="
-6f6e6f4f6b9a20c95d359ae7410c31478968e5c10b77e73b5c5ca5daa1c01a8a17713d69b9713102621b35aa6b603def0dfe1122a6393917b76ff1abbed2a62c mediastreamer2-5.2.86.tar.gz
-d0158e03a7552580a9d9f04226c18a31a23d3cc502d52b51a9b083a5c32094ea7349495a7f74316eb727c2478a80b0385e1a28798b5b7d6e85e463485e33a822 missing-def-o-binary.patch
+1c3da2ccf14e01f5f439e0264b130088f592c659999dcf3da5f429a7c3caf1ea535c483ef197302eb3f3bfc28ba524dbb034fc2265f9cb59f3872016377488b8 mediastreamer2-5.3.38.tar.gz
+964467b5f493915d4e920b3afce9ce0cacc9bb34a7886c4b4e06340d6fa646754a03ce18ec66a4a3b82d63ec52330a0b21c842d80e47a6685eb942bb01b1869b fix-cmake-path.patch
+9aa98303d53c622cd8ee6386544db337eb5069d86754876d6901a0d9bebe6e6d623f41c7ae900bb2649254b503ee63367ce612bc4bec9423fc3d57cfece119c2 fix-soname.patch
"
diff --git a/testing/mediastreamer2/fix-cmake-path.patch b/testing/mediastreamer2/fix-cmake-path.patch
new file mode 100644
index 00000000000..48323e8f3cd
--- /dev/null
+++ b/testing/mediastreamer2/fix-cmake-path.patch
@@ -0,0 +1,14 @@
+Adapted from https://github.com/OpenMandrivaAssociation/mediastreamer/blob/master/mediastreamer2-5.3.6-cmake-config-location.patch
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -680,7 +680,7 @@ if(ENABLE_TOOLS AND NOT ANDROID)
+ )
+
+ include(CMakePackageConfigHelpers)
+-set(CMAKE_MODULES_INSTALL_DIR "${CMAKE_INSTALL_DATADIR}/${PROJECT_NAME}/cmake")
++set(CMAKE_MODULES_INSTALL_DIR "${CMAKE_INSTALL_LIBDIR}/cmake/${PROJECT_NAME}/")
+ configure_package_config_file("cmake/${PROJECT_NAME}Config.cmake.in" "${PROJECT_BINARY_DIR}/${PROJECT_NAME}Config.cmake"
+ INSTALL_DESTINATION "${CMAKE_MODULES_INSTALL_DIR}"
+ PATH_VARS MS2_PLUGINS_DIR
+
diff --git a/testing/mediastreamer2/fix-soname.patch b/testing/mediastreamer2/fix-soname.patch
new file mode 100644
index 00000000000..05e36b57cf4
--- /dev/null
+++ b/testing/mediastreamer2/fix-soname.patch
@@ -0,0 +1,12 @@
+Patch-Source: https://github.com/OpenMandrivaAssociation/mediastreamer/blob/master/mediastreamer2-5.3.6-soname.patch
+
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -617,6 +617,7 @@ if(BUILD_SHARED_LIBS)
+ set_target_properties(mediastreamer2 PROPERTIES SOVERSION ${MEDIASTREAMER_SO_VERSION})
+ else()
+
++ set_target_properties(mediastreamer2 PROPERTIES SOVERSION ${MEDIASTREAMER_SO_VERSION})
+
+ #Workaround for the Debian 11 issue with conflict between libc and libtirpc
+ #/usr/bin/ld: /lib/x86_64-linux-gnu/libtirpc.so.3: warning: common of `rpc_createerr@@GLIBC_2.2.5' overridden by definition from /lib/x86_64-linux-gnu/libc.so.6
diff --git a/testing/mediastreamer2/missing-def-o-binary.patch b/testing/mediastreamer2/missing-def-o-binary.patch
deleted file mode 100644
index 7515a6c85e3..00000000000
--- a/testing/mediastreamer2/missing-def-o-binary.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/src/otherfilters/mspcapfileplayer.c b/src/otherfilters/mspcapfileplayer.c
-index 1337089..8841882 100644
---- a/src/otherfilters/mspcapfileplayer.c
-+++ b/src/otherfilters/mspcapfileplayer.c
-@@ -33,8 +33,9 @@
- #include <fcntl.h>
- #include <sys/types.h>
- #include <sys/stat.h>
--
--
-+#ifndef O_BINARY
-+#define O_BINARY 0
-+#endif
-
- static int player_close(MSFilter *f, void *arg);
-