summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2022-05-07 16:36:24 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2022-05-07 16:36:24 +0200
commit9a09fd40548cfa48baf0c0e77254610bb22f37ba (patch)
treeb4a561b90235784b9fd21c0ee050b5503a8eeba6
parent1b109fee883a36358f55b36e1496ef1a3caf89bb (diff)
downloadaports-9a09fd40548cfa48baf0c0e77254610bb22f37ba.zip
main/cdparanoia: remove no-cuserid.patch
This has been fixed in musl v1.2.3. See: https://git.musl-libc.org/cgit/musl/commit/?id=ef137da6428c342baabd3bcf9b5e91f75acefa64
-rw-r--r--main/cdparanoia/APKBUILD10
-rw-r--r--main/cdparanoia/no-cuserid.patch32
2 files changed, 5 insertions, 37 deletions
diff --git a/main/cdparanoia/APKBUILD b/main/cdparanoia/APKBUILD
index 5afc0c0b678..2d1c905184a 100644
--- a/main/cdparanoia/APKBUILD
+++ b/main/cdparanoia/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cdparanoia
pkgver=10.2
-pkgrel=9
+pkgrel=10
pkgdesc="An audio CD extraction application"
url="http://www.xiph.org/paranoia"
arch="all"
@@ -12,8 +12,7 @@ makedepends="libtool autoconf automake linux-headers"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
source="http://downloads.xiph.org/releases/cdparanoia/cdparanoia-III-$pkgver.src.tgz
gcc.patch
- fix-includes.patch
- no-cuserid.patch"
+ fix-includes.patch"
builddir="$srcdir/$pkgname-III-$pkgver"
prepare() {
@@ -48,7 +47,8 @@ libs() {
mv "$pkgdir"/usr/lib "$subpkgdir"/usr/
}
-sha512sums="4ab0a0f5ef44d56c1af72d1fc1035566a1a89c4eeddb9e8baea675fe51c06138d913342afc8bed167d9fa55672fa25a2763ce21f7e24c1232e4739aff20733a7 cdparanoia-III-10.2.src.tgz
+sha512sums="
+4ab0a0f5ef44d56c1af72d1fc1035566a1a89c4eeddb9e8baea675fe51c06138d913342afc8bed167d9fa55672fa25a2763ce21f7e24c1232e4739aff20733a7 cdparanoia-III-10.2.src.tgz
27bf216e8b5b9d6971e3999166544025f166587df06065b89657dac62d0d53c01b76f53146c1e9a400dd71460567fadb8fd4ce00576836f972914d69e8855909 gcc.patch
e8a5ef0f5bcdba697d2d49e31346832bfa2460e6f6cac9256420f57c74a5da2945bdc664368c91365a880ba76e638f58773468d8e8bd16e7afcaff955a1a82ce fix-includes.patch
-52882bdc689e1a34bc0f3961aa649f400232a3fe769526a01fcbff4ba0d5183c1ad0737265b69668b857b0887b4e4e3f2c78bad913329cc7b621b14d47e873f9 no-cuserid.patch"
+"
diff --git a/main/cdparanoia/no-cuserid.patch b/main/cdparanoia/no-cuserid.patch
deleted file mode 100644
index dd6417f8367..00000000000
--- a/main/cdparanoia/no-cuserid.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Since IEEE 1003.1-1988 cuserid is not standardized anymore. The musl
-libc, used by Alpine Linux, currently does not supporting using it with
-a NULL pointer argument [1]. Doing so causes a segmentation fault, to
-fix this remove use of cuserid entirely. This is currently achieved by
-not including the user name in the error message, while it would be
-possible to achieve the same output using getpwuid(geteuid()) this
-requires error handling and would make the patch more complicated.
-
-[1]: https://www.openwall.com/lists/musl/2020/01/29/2
-
-diff -upr cdparanoia-III-10.2.orig/interface/scan_devices.c cdparanoia-III-10.2/interface/scan_devices.c
---- cdparanoia-III-10.2.orig/interface/scan_devices.c 2020-02-12 20:29:46.232958848 +0100
-+++ cdparanoia-III-10.2/interface/scan_devices.c 2020-02-12 20:30:06.336297868 +0100
-@@ -6,8 +6,6 @@
- *
- ******************************************************************/
-
--#define _GNU_SOURCE /* get cuserid */
--#define _USE_XOPEN /* get cuserid */
- #include <limits.h>
- #include <stdio.h>
- #include <unistd.h>
-@@ -93,8 +91,7 @@ cdrom_drive *cdda_find_a_cdrom(int messa
- i++;
- }
- idmessage(messagedest,messages,
-- "\n\nNo cdrom drives accessible to %s found.\n",
-- cuserid(NULL));
-+ "\n\nNo cdrom drives accessible to current user found.\n", NULL);
- return(NULL);
- }
-