summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-09-06 05:21:38 +0000
committerCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-09-06 05:21:38 +0000
commit5282adacb1a9cad3952beb5344857075e822e84c (patch)
treecc7e88d23deb45f6b68927c961d1fead52109ccc
parentb9a7117fb8d79c01e3f734296f7afee26a650d41 (diff)
downloadaports-5282adacb1a9cad3952beb5344857075e822e84c.zip
community/appstream-generator: further increase test timeout
limit this to loongarch64
-rw-r--r--community/appstream-generator/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/community/appstream-generator/APKBUILD b/community/appstream-generator/APKBUILD
index ffb639ddbc8..28167009939 100644
--- a/community/appstream-generator/APKBUILD
+++ b/community/appstream-generator/APKBUILD
@@ -39,8 +39,15 @@ build() {
}
check() {
- # the loongarch64 builder times out with the standard timeout
- meson test --timeout-multiplier 3 --no-rebuild --print-errorlogs -C output
+ case "$CARCH" in
+ loongarch64)
+ # asgen_tests times out with the standard timeout on the builder
+ meson test --timeout-multiplier 10 --no-rebuild --print-errorlogs -C output
+ ;;
+ *)
+ meson test --no-rebuild --print-errorlogs -C output
+ ;;
+ esac
}
package() {