summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2022-12-14 13:18:18 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2022-12-14 19:50:13 +0100
commit308ffd8b1d6c776b4e40b36640eca16ad30ba95b (patch)
tree3940fa898bebd8d5e06b88e51bc8b812a7825a55
parente87e520a8c9884b2a634b1a3eea32c0a380f226d (diff)
downloadaports-308ffd8b1d6c776b4e40b36640eca16ad30ba95b.zip
main/dahdi-*: remove
It is unlikely that anyone is still using ISDN. Remove.
-rw-r--r--main/dahdi-linux-lts/APKBUILD80
-rw-r--r--main/dahdi-linux-lts/dahdi-bri_dchan.patch167
-rw-r--r--main/dahdi-linux-lts/dahdi-depmod.patch22
-rw-r--r--main/dahdi-linux/APKBUILD27
-rw-r--r--main/dahdi-tools/APKBUILD49
-rw-r--r--main/dahdi-tools/dahdi-tools.initd21
-rw-r--r--main/dahdi-tools/fix-musl.patch36
7 files changed, 0 insertions, 402 deletions
diff --git a/main/dahdi-linux-lts/APKBUILD b/main/dahdi-linux-lts/APKBUILD
deleted file mode 100644
index 983db7d7fb7..00000000000
--- a/main/dahdi-linux-lts/APKBUILD
+++ /dev/null
@@ -1,80 +0,0 @@
-# Contributor: Timo Teras <timo.teras@iki.fi>
-# Contributor: wener <wenermail@gmail.com>
-# Maintainer: wener <wenermail@gmail.com>
-
-# when changing _ver we *must* bump _rel
-_name=dahdi-linux
-_ver=3.2.0
-_rel=1
-# when changing _kver/_krel make sure _rel=0
-_flavor=${FLAVOR:-lts}
-_kpkg=linux-$_flavor
-_kver=5.15.82
-_krel=0
-
-_kpkgver="$_kver-r$_krel"
-_kabi="$_kver-$_krel-$_flavor"
-
-pkgname=$_name-$_flavor
-pkgver=$_kver
-pkgrel=$(( _krel + _rel ))
-
-pkgdesc="Digium Asterisk Hardware Device Interface drivers"
-url="https://www.asterisk.org/"
-arch="x86_64"
-license="GPL-2.0-or-later"
-depends="dahdi-linux $_kpkg=$_kpkgver"
-# we need wget and tar because make install downloads firmware and uses fancy
-# options for tar and wget.
-makedepends="$_kpkg-dev=$_kpkgver wget tar perl"
-subpackages="$pkgname-dev"
-source="https://downloads.digium.com/pub/telephony/dahdi-linux/releases/${_name}-$_ver.tar.gz
- dahdi-depmod.patch
- dahdi-bri_dchan.patch
- "
-
-builddir="$srcdir/$_name-$_ver"
-
-prepare() {
- default_prepare
- # verify the kernel version
- local _kapkbuild="$startdir"/../../main/linux-$_flavor/APKBUILD
- if [ -f $_kapkbuild ]; then
- ( . $_kapkbuild
- pkgname=$_name-$_flavor
- [ "$_kver" != "$pkgver" ] && die "please update _kver to $pkgver"
- [ "$_krel" != "$pkgrel" ] && die "please update _krel to $pkgrel"
- return 0
- )
- fi
-}
-
-build() {
- cd "$srcdir/$_name-$_ver"
- make KVERS="$_kabi" DYNFS="yes"
-}
-
-package() {
- cd "$srcdir/$_name-$_ver"
- make KVERS="$_kabi" DYNFS="yes" \
- DESTDIR="$pkgdir" install-modules
- rm -rf "$pkgdir"/lib/firmware "$pkgdir"/usr/lib/hotplug/firmware \
- "$pkgdir"/usr/include || true
-}
-
-# since we sourced the APKBUILD above we got the dev() function there to
-# so we override it again.
-depends_dev="dahdi-linux-dev"
-dev() {
- default_dev
- local dir="$subpkgdir"/usr/src/dahdi-headers-"$_kabi"
- install -D "$srcdir"/$_name-$_ver/drivers/dahdi/Module.symvers \
- "$dir"/drivers/dahdi/Module.symvers
- ln -s /usr/include "$dir"/include
-}
-
-sha512sums="
-cb4b06d5a83aae7ce54049137d989fa6275367debc77a1df64cc36ba1bda08a058ea92f01bb873bcd83c3c7d58ff4c5da42c67bbbe8a02b8f4f0e12348c4a072 dahdi-linux-3.2.0.tar.gz
-aba01eb90d9db1c595ff22078c76aadb20900486b5794d38b7ee61fa30d2fb51be318a4d059246017640447aee03fb09bb5514c818e3caa1cd98e331ec065173 dahdi-depmod.patch
-fa2fa9e96eefc0f31a1a4a8f8f44e77936f6da0d7b74fe3c3d1f0de085621744ae4367932ac97a10b7f96b7d0954843b0bfe07a251b85434079cc6da29e243ba dahdi-bri_dchan.patch
-"
diff --git a/main/dahdi-linux-lts/dahdi-bri_dchan.patch b/main/dahdi-linux-lts/dahdi-bri_dchan.patch
deleted file mode 100644
index 8d2ba97fd1e..00000000000
--- a/main/dahdi-linux-lts/dahdi-bri_dchan.patch
+++ /dev/null
@@ -1,167 +0,0 @@
-# Translate the D channels to a standard channel data.
-# The HFC chipset provides us the D channel as data, but
-# Zaptel expects it as a standard channel with 1000 samples
-# per second.
-
-Index: dahdi-linux-2.5.0/include/dahdi/kernel.h
-===================================================================
---- dahdi-linux-2.5.0.orig/include/dahdi/kernel.h 2011-06-29 18:32:40.000000000 +0300
-+++ dahdi-linux-2.5.0/include/dahdi/kernel.h 2011-08-15 14:14:26.000000000 +0300
-@@ -413,6 +413,13 @@
- int statcount;
- int lastnumbufs;
- #endif
-+#ifdef CONFIG_DAHDI_BRI_DCHANS
-+ int bytes2receive;
-+ int maxbytes2transmit; /* size of the tx buffer in the card driver */
-+ int bytes2transmit;
-+ int eofrx;
-+ int eoftx;
-+#endif
- spinlock_t lock;
- char name[40];
- /* Specified by DAHDI */
-@@ -723,6 +730,9 @@
- DAHDI_FLAGBIT_TXUNDERRUN = 22, /*!< Transmit underrun condition */
- DAHDI_FLAGBIT_RXOVERRUN = 23, /*!< Receive overrun condition */
- DAHDI_FLAGBIT_DEVFILE = 25, /*!< Channel has a sysfs dev file */
-+#if defined(CONFIG_DAHDI_BRI_DCHANS)
-+ DAHDI_FLAGBIT_BRIDCHAN = 26, /*!< hardhdlc-like handling of the D channel */
-+#endif
- };
-
- #ifdef CONFIG_DAHDI_NET
-@@ -789,6 +799,7 @@
- #define DAHDI_FLAG_BUFEVENTS DAHDI_FLAG(BUFEVENTS)
- #define DAHDI_FLAG_TXUNDERRUN DAHDI_FLAG(TXUNDERRUN)
- #define DAHDI_FLAG_RXOVERRUN DAHDI_FLAG(RXOVERRUN)
-+#define DAHDI_FLAG_BRIDCHAN DAHDI_FLAG(BRIDCHAN)
-
- struct file;
-
-Index: dahdi-linux-2.5.0/include/dahdi/dahdi_config.h
-===================================================================
---- dahdi-linux-2.5.0.orig/include/dahdi/dahdi_config.h 2011-01-05 17:52:03.000000000 +0200
-+++ dahdi-linux-2.5.0/include/dahdi/dahdi_config.h 2011-08-15 14:13:01.000000000 +0300
-@@ -195,4 +195,10 @@
- */
- /* #define CONFIG_DAHDI_MIRROR */
-
-+/*
-+ * Uncomment the following for BRI D channels
-+ *
-+ */
-+#define CONFIG_DAHDI_BRI_DCHANS
-+
- #endif
-Index: dahdi-linux-2.5.0/drivers/dahdi/dahdi-base.c
-===================================================================
---- dahdi-linux-2.5.0.orig/drivers/dahdi/dahdi-base.c 2011-07-21 19:26:31.000000000 +0300
-+++ dahdi-linux-2.5.0/drivers/dahdi/dahdi-base.c 2011-08-15 14:13:01.000000000 +0300
-@@ -7224,11 +7224,40 @@
- *(txb++) = fasthdlc_tx_run_nocheck(&ms->txhdlc);
- }
- bytes -= left;
-+#ifdef CONFIG_DAHDI_BRI_DCHANS
-+ } else if (test_bit(DAHDI_FLAGBIT_BRIDCHAN, &ms->flags)) {
-+ /*
-+ * Let's get this right, we want to transmit complete frames only.
-+ * The card driver will do the dirty HDLC work for us.
-+ * txb (transmit buffer) is supposed to be big enough to store one frame
-+ * we will make this as big as the D fifo (1KB or 2KB)
-+ */
-+
-+ /* there are 'left' bytes in the user buffer left to transmit */
-+ left = ms->writen[ms->outwritebuf] - ms->writeidx[ms->outwritebuf] - 2;
-+ if (left > ms->maxbytes2transmit) {
-+ memcpy(txb, buf + ms->writeidx[ms->outwritebuf], ms->maxbytes2transmit);
-+ ms->writeidx[ms->outwritebuf] += ms->maxbytes2transmit;
-+ txb += ms->maxbytes2transmit;
-+ ms->bytes2transmit = ms->maxbytes2transmit;
-+ ms->eoftx = 0;
-+ } else {
-+ memcpy(txb, buf + ms->writeidx[ms->outwritebuf], left);
-+ ms->writeidx[ms->outwritebuf] += left + 2;
-+ txb += left + 2;
-+ ms->bytes2transmit = left;
-+ ms->eoftx = 1;
-+ }
-+ bytes = 0;
-+#endif
- } else {
- memcpy(txb, buf + ms->writeidx[ms->outwritebuf], left);
- ms->writeidx[ms->outwritebuf]+=left;
- txb += left;
- bytes -= left;
-+#if defined(CONFIG_DAHDI_BRI_DCHANS)
-+ ms->bytes2transmit=DAHDI_CHUNKSIZE;
-+#endif
- }
- /* Check buffer status */
- if (ms->writeidx[ms->outwritebuf] >= ms->writen[ms->outwritebuf]) {
-@@ -7285,6 +7314,17 @@
- /* Transmit a flag if this is an HDLC channel */
- if (ms->flags & DAHDI_FLAG_HDLC)
- fasthdlc_tx_frame_nocheck(&ms->txhdlc);
-+#if defined(CONFIG_DAHDI_BRI_DCHANS)
-+ if (test_bit(DAHDI_FLAGBIT_BRIDCHAN, &ms->flags)) {
-+ // if (ms->bytes2transmit > 0) {
-+ // txb += 2;
-+ // ms->bytes2transmit -= 2;
-+ bytes=0;
-+ ms->eoftx = 1;
-+// printk(KERN_CRIT "zaptel EOF(%d) bytes2transmit %d\n",ms->eoftx,ms->bytes2transmit);
-+ // }
-+ }
-+#endif
- #ifdef CONFIG_DAHDI_NET
- if (dahdi_have_netdev(ms))
- netif_wake_queue(chan_to_netdev(ms));
-@@ -7346,6 +7386,12 @@
- }
- needtxunderrun += bytes;
- bytes = 0;
-+#if defined(CONFIG_DAHDI_BRI_DCHANS)
-+ } else if (test_bit(DAHDI_FLAGBIT_BRIDCHAN, &ms->flags)) {
-+ ms->bytes2transmit = 0;
-+ ms->eoftx = 0;
-+ bytes = 0;
-+#endif
- } else {
- memset(txb, DAHDI_LIN2X(0, ms), bytes); /* Lastly we use silence on telephony channels */
- needtxunderrun += bytes;
-@@ -8267,6 +8313,14 @@
- int res;
- int left, x;
-
-+#if defined(CONFIG_DAHDI_BRI_DCHANS)
-+ if (test_bit(DAHDI_FLAGBIT_BRIDCHAN, &ms->flags)) {
-+ bytes = ms->bytes2receive;
-+ if (bytes < 1) return;
-+// printk(KERN_CRIT "bytes2receive %d\n",ms->bytes2receive);
-+ }
-+#endif
-+
- while(bytes) {
- #if defined(CONFIG_DAHDI_NET) || defined(CONFIG_DAHDI_PPP)
- skb = NULL;
-@@ -8324,6 +8378,19 @@
- }
- }
- }
-+#ifdef CONFIG_DAHDI_BRI_DCHANS
-+ } else if (test_bit(DAHDI_FLAGBIT_BRIDCHAN, &ms->flags)) {
-+ memcpy(buf + ms->readidx[ms->inreadbuf], rxb, left);
-+ rxb += left;
-+ ms->readidx[ms->inreadbuf] += left;
-+ bytes -= left;
-+ if (ms->eofrx == 1) {
-+ eof=1;
-+ }
-+// printk(KERN_CRIT "receiving %d bytes\n",ms->bytes2receive);
-+ ms->bytes2receive = 0;
-+ ms->eofrx = 0;
-+#endif
- } else {
- /* Not HDLC */
- memcpy(buf + ms->readidx[ms->inreadbuf], rxb, left);
diff --git a/main/dahdi-linux-lts/dahdi-depmod.patch b/main/dahdi-linux-lts/dahdi-depmod.patch
deleted file mode 100644
index 289aad403b3..00000000000
--- a/main/dahdi-linux-lts/dahdi-depmod.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: dahdi-linux-2.0.0-rc4/Makefile
-===================================================================
---- dahdi-linux-2.0.0-rc4.orig/Makefile 2008-09-09 14:07:23.000000000 +0300
-+++ dahdi-linux-2.0.0-rc4/Makefile 2008-09-09 14:12:31.000000000 +0300
-@@ -190,7 +190,7 @@
- build_tools/uninstall-modules dahdi $(KVERS)
- endif
- $(KMAKE) INSTALL_MOD_PATH=$(DESTDIR) INSTALL_MOD_DIR=dahdi modules_install
-- [ `id -u` = 0 ] && /sbin/depmod -a $(KVERS) || :
-+ [ -z "$(DESTDIR)" -a `id -u` = 0 ] && /sbin/depmod -a $(KVERS) || :
-
- uninstall-modules:
- ifdef DESTDIR
-@@ -203,7 +203,7 @@
- rm -rf /lib/modules/$(KVERS)/dahdi; \
- echo "done."; \
- fi
-- [ `id -u` = 0 ] && /sbin/depmod -a $(KVERS) || :
-+ [ -z "$(DESTDIR)" -a `id -u` = 0 ] && /sbin/depmod -a $(KVERS) || :
- endif
-
- update:
diff --git a/main/dahdi-linux/APKBUILD b/main/dahdi-linux/APKBUILD
deleted file mode 100644
index a37e5f92c0e..00000000000
--- a/main/dahdi-linux/APKBUILD
+++ /dev/null
@@ -1,27 +0,0 @@
-# Contributor: Timo Teras <timo.teras@iki.fi>
-# Maintainer: Timo Teras <timo.teras@iki.fi>
-pkgname=dahdi-linux
-pkgver=3.2.0
-pkgrel=0
-pkgdesc="Firmware for Digium Asterisk Hardware Device Interface drivers"
-url="https://www.asterisk.org"
-arch="noarch"
-license="GPL-2.0-only"
-makedepends="wget tar"
-subpackages="$pkgname-dev"
-source="https://downloads.digium.com/pub/telephony/dahdi-linux/releases/dahdi-linux-$pkgver.tar.gz"
-options="net"
-
-# We online install the firmwares in this package since those are common for all
-# kernel flavors. We also install the headers for the -dev package.
-#
-# The kernel drivers themselves are built from separate build recipe.
-
-package() {
- make -j1 DESTDIR="$pkgdir" HOTPLUG_FIRMWARE=yes \
- install-include install-firmware
-}
-
-sha512sums="
-cb4b06d5a83aae7ce54049137d989fa6275367debc77a1df64cc36ba1bda08a058ea92f01bb873bcd83c3c7d58ff4c5da42c67bbbe8a02b8f4f0e12348c4a072 dahdi-linux-3.2.0.tar.gz
-"
diff --git a/main/dahdi-tools/APKBUILD b/main/dahdi-tools/APKBUILD
deleted file mode 100644
index c6bb6e50937..00000000000
--- a/main/dahdi-tools/APKBUILD
+++ /dev/null
@@ -1,49 +0,0 @@
-# Contributor: Timo Teras <timo.teras@iki.fi>
-# Maintainer: Timo Teras <timo.teras@iki.fi>
-pkgname=dahdi-tools
-pkgver=3.2.0
-pkgrel=0
-pkgdesc="Digium Asterisk Hardware Device Interface management utilities"
-url="https://www.asterisk.org"
-arch="all"
-license="GPL-2.0-or-later"
-depends_dev="bsd-compat-headers linux-headers dahdi-linux-dev newt-dev"
-makedepends="perl file autoconf automake libtool $depends_dev"
-subpackages="$pkgname-doc $pkgname-dev"
-source="https://downloads.digium.com/pub/telephony/dahdi-tools/releases/dahdi-tools-$pkgver.tar.gz
- fix-musl.patch
- $pkgname.initd
- "
-
-prepare() {
- default_prepare
- autoreconf -fi
-}
-
-
-build() {
- eval local $(perl -V:vendorlib)
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/infoa \
- --with-perllib="$vendorlib"
- sed -i -e 's/$(CC) $(LDFLAGS) -o $@ $^/$(CC) $^ $(LDFLAGS) -o $@/' \
- Makefile
- make
-}
-
-package() {
- make -j1 DESTDIR="$pkgdir" install
- install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/dahdi
- rm -rf "$pkgdir"/usr/lib/dracut # We use mkinitfs, not dracut
-}
-
-sha512sums="
-29df9a768c6db872bd51926dac11178400a03e2e1d0771ae163433ce300af71691f5c7a60f8756c0e6cef8a43f1331944cb4e44393f04a0ff8dee19bc9e7cf16 dahdi-tools-3.2.0.tar.gz
-45955caf04368ff30d60db0b3e892d940c9ac0422b337186ed251108ce25ab305d4590efff452f53f160a53fcd26a273f21d6d093307b426a3a2a6df53584daa fix-musl.patch
-3850ab9e323ec31d676d311c97d0cde70b809379b6c01c8ff6d5a01a860eb43bf3f18f2de53e952365d17f40638c7cb0481682d96cea5b7fdb1423d3e762e2f3 dahdi-tools.initd
-"
diff --git a/main/dahdi-tools/dahdi-tools.initd b/main/dahdi-tools/dahdi-tools.initd
deleted file mode 100644
index 42092c7375b..00000000000
--- a/main/dahdi-tools/dahdi-tools.initd
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/sbin/openrc-run
-
-conf=/etc/dahdi/system.conf
-
-depend() {
- before asterisk
- after hwdrivers modules
- keyword novserver
-}
-
-start() {
- ebegin "Starting dahdi"
- /usr/sbin/dahdi_cfg
- eend $?
-}
-
-stop() {
- ebegin "Stopping dahdi"
- /usr/sbin/dahdi_cfg -s
- eend $?
-}
diff --git a/main/dahdi-tools/fix-musl.patch b/main/dahdi-tools/fix-musl.patch
deleted file mode 100644
index 01a0a302bf1..00000000000
--- a/main/dahdi-tools/fix-musl.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -ru dahdi-tools-2.11.1.orig/xpp/hexfile.h dahdi-tools-2.11.1/xpp/hexfile.h
---- dahdi-tools-2.11.1.orig/xpp/hexfile.h 2016-03-02 00:04:19.000000000 +0200
-+++ dahdi-tools-2.11.1/xpp/hexfile.h 2017-05-29 09:30:50.034438806 +0300
-@@ -26,6 +26,7 @@
- #include <stdarg.h>
- #include <stdio.h>
- #include <stdint.h>
-+#include <sys/cdefs.h>
- #include <sys/param.h>
- #include <syslog.h>
- #define PACKED __attribute__((packed))
-diff -ru dahdi-tools-2.11.1.orig/xpp/xtalk/debug.c dahdi-tools-2.11.1/xpp/xtalk/debug.c
---- dahdi-tools-2.11.1.orig/xpp/xtalk/debug.c 2016-03-02 00:04:19.000000000 +0200
-+++ dahdi-tools-2.11.1/xpp/xtalk/debug.c 2017-05-29 09:30:02.193881232 +0300
-@@ -26,7 +26,6 @@
- #include <stdlib.h>
- #include <stdarg.h>
- #include <syslog.h>
--#include <execinfo.h>
- #include <xtalk/debug.h>
- #include <autoconfig.h>
-
-@@ -61,6 +60,7 @@
- /* from glibc info(1) */
- void print_backtrace(FILE *fp)
- {
-+#if 0
- void *array[10];
- size_t size;
- char **strings;
-@@ -71,4 +71,5 @@
- for (i = 0; i < size; i++)
- fprintf(fp, "%s\n", strings[i]);
- free(strings);
-+#endif
- }