summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-06-19 13:31:31 +0000
committerpsykose <alice@ayaya.dev>2023-06-19 15:32:06 +0200
commit2bed08056906ea29637ff0808b25b97972737dfe (patch)
tree5c036348cd441b0589a6498f9a6336f653bc14a0
parentf811399daf993c444c16fbf6095149169d11bdf2 (diff)
downloadaports-2bed08056906ea29637ff0808b25b97972737dfe.zip
main/gdb: depend on musl-dbg directly
-rw-r--r--main/gdb/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/main/gdb/APKBUILD b/main/gdb/APKBUILD
index 1298c20bbd5..107aff3dc22 100644
--- a/main/gdb/APKBUILD
+++ b/main/gdb/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gdb
pkgver=13.2
-pkgrel=1
+pkgrel=2
pkgdesc="The GNU Debugger"
url="https://www.gnu.org/software/gdb/"
arch="all"
@@ -81,6 +81,10 @@ build() {
}
package() {
+ # backtracing/debugging pretty much anything is going to need libc debug symbols
+ # not everything, but the common case needs this, and it's a small dep in comparison
+ depends="musl-dbg"
+
cd "$builddir"/vanilla
make DESTDIR="$pkgdir" install