summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-04-20 04:00:16 +0000
committerpsykose <alice@ayaya.dev>2023-04-20 06:00:16 +0200
commit18c54152d924f73eca881afad938e038421065c8 (patch)
treed8db92c4581603f743af33461efe6a44f317ed78
parentfe0a75fee268a7d8cdcd66a04fddec46bea16d4c (diff)
downloadaports-18c54152d924f73eca881afad938e038421065c8.zip
main/openldap: fix implicits
-rw-r--r--main/openldap/APKBUILD4
-rw-r--r--main/openldap/implicit.patch171
2 files changed, 174 insertions, 1 deletions
diff --git a/main/openldap/APKBUILD b/main/openldap/APKBUILD
index ea2eaf9dc06..614ce640f68 100644
--- a/main/openldap/APKBUILD
+++ b/main/openldap/APKBUILD
@@ -33,7 +33,7 @@
#
pkgname=openldap
pkgver=2.6.4
-pkgrel=2
+pkgrel=3
pkgdesc="LDAP Server"
url="https://www.openldap.org/"
arch="all"
@@ -89,6 +89,7 @@ source="https://www.openldap.org/software/download/OpenLDAP/openldap-release/ope
0007-Use-correct-extension-for-slapd-modules.patch
0008-Remove-pidfile-and-argsfile.patch
0009-Include-more-schemas-in-default-config.patch
+ implicit.patch
lloadd.conf
slapd.initd
@@ -390,6 +391,7 @@ f88de2f92a31f1b906e850daa1b518fc90822e668c9ca99c33934304d260237a1406cb845c2f4985
30af37e70a53a55c56bb0e74eee770a00abe83d4b0a787845363ccff564b49b8ba20c907bb976442b4dc2278db7b0a039a11c85dd40a547af6de9a7f1591328f 0007-Use-correct-extension-for-slapd-modules.patch
eaadec2a58a7f117c67b10673e26fe8c38e40ae4c1ae5fda9004c9bbebca81b6cd51cc482f28d94dacd8154ed800fd1e90f48807970f54652bfc021f8039806e 0008-Remove-pidfile-and-argsfile.patch
1c2a18280ea06f8095f013c110f8b1b0779c3dc89aa19158cdedbe3a7e1019e7ea5a503cba4d3e3ae824423ded22b2ef334665d2281969ac3b0efb96de34e37e 0009-Include-more-schemas-in-default-config.patch
+933fe94a1fd4330bf583f837ee8b9b7abdaa8cf755579f98ebffd17216731f441ed7a4777c9d24aa0d8d59b9db5dae01e31392f97595fbe59602dd6032a5289a implicit.patch
c47a415a2a9cd98bb448820b981f40df82b4825e0ebcc8a5fb3c604d15e8f57ea1578afca6b3aa90351fd13e7ddba7dc7452bdb669df4a402f02990ca154e34e lloadd.conf
d8bd06f56a816851015488cccb352657df09f1aed9990fc2870208ffb1c5c499ac1d7592c42e8fa6e4a26a6bb2535f57e91d3a2aecfb38cf15d86de20e0e69a7 slapd.initd
5898139481b3317b257ce1bfab401dd4e111a8f7ebb02262a8dcb165c6416fba1e5bb070cdf618918f018d2ad942d9514ce6a9b2ab1c57ac30ec75fb53b04af1 slapd.confd
diff --git a/main/openldap/implicit.patch b/main/openldap/implicit.patch
new file mode 100644
index 00000000000..eb1e1c07110
--- /dev/null
+++ b/main/openldap/implicit.patch
@@ -0,0 +1,171 @@
+fix configure tests
+--
+From ee4983302d6f052e77ab0332d2a128d169c2eacb Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Arsen=20Arsenovi=C4=87?= <arsen@aarsen.me>
+Date: Tue, 15 Nov 2022 21:45:27 +0100
+Subject: [PATCH] Remove default-int/k&r declarations from the configure macros
+
+Recently, Clang tried to switch to having K&R prototypes and other
+non-strictly-conforming prototypes error out, as a result of C2x changes
+to the standard. These have been located across many packages, and
+range in severity from mild compile errors to runtime misconfiguration
+as a result of broken configure scripts.
+
+This covers all the instances I could find by grepping around the
+codebase, and gets OpenLDAP building on my system.
+
+Bug: https://bugs.gentoo.org/871288
+Bug: https://bugs.gentoo.org/871372
+--- a/build/openldap.m4
++++ b/build/openldap.m4
+@@ -154,6 +154,7 @@ fi
+ if test $ol_cv_header_stdc = yes; then
+ # /bin/cc in Irix-4.0.5 gets non-ANSI ctype macros unless using -ansi.
+ AC_RUN_IFELSE([AC_LANG_SOURCE([[#include <ctype.h>
++#include <stdlib.h>
+ #ifndef HAVE_EBCDIC
+ # define ISLOWER(c) ('a' <= (c) && (c) <= 'z')
+ # define TOUPPER(c) (ISLOWER(c) ? 'A' + ((c) - 'a') : (c))
+@@ -394,9 +395,7 @@ AC_DEFUN([OL_PTHREAD_TEST_FUNCTION],[[
+ AC_DEFUN([OL_PTHREAD_TEST_PROGRAM],
+ [AC_LANG_SOURCE([OL_PTHREAD_TEST_INCLUDES
+
+-int main(argc, argv)
+- int argc;
+- char **argv;
++int main(int argc, char **argv)
+ {
+ OL_PTHREAD_TEST_FUNCTION
+ }
+@@ -518,7 +517,7 @@ AC_CACHE_CHECK([for compatible POSIX regex],ol_cv_c_posix_regex,[
+ #include <sys/types.h>
+ #include <regex.h>
+ static char *pattern, *string;
+-main()
++int main(void)
+ {
+ int rc;
+ regex_t re;
+@@ -545,7 +544,8 @@ AC_DEFUN([OL_C_UPPER_LOWER],
+ [AC_CACHE_CHECK([if toupper() requires islower()],ol_cv_c_upper_lower,[
+ AC_RUN_IFELSE([AC_LANG_SOURCE([[
+ #include <ctype.h>
+-main()
++#include <stdlib.h>
++int main(void)
+ {
+ if ('C' == toupper('C'))
+ exit(0);
+@@ -603,7 +603,7 @@ AC_DEFUN([OL_NONPOSIX_STRERROR_R],
+ ]])],[ol_cv_nonposix_strerror_r=yes],[ol_cv_nonposix_strerror_r=no])
+ else
+ AC_RUN_IFELSE([AC_LANG_SOURCE([[
+- main() {
++ int main(void) {
+ char buf[100];
+ buf[0] = 0;
+ strerror_r( 1, buf, sizeof buf );
+--- a/configure.ac
++++ b/configure.ac
+@@ -1031,7 +1031,11 @@ dnl ----------------------------------------------------------------
+ AC_CHECK_HEADERS( sys/epoll.h )
+ if test "${ac_cv_header_sys_epoll_h}" = yes; then
+ AC_MSG_CHECKING(for epoll system call)
+- AC_RUN_IFELSE([AC_LANG_SOURCE([[int main(int argc, char **argv)
++ AC_RUN_IFELSE([AC_LANG_SOURCE([[#include <stdlib.h>
++#ifdef HAVE_SYS_POLL_H
++#include <sys/epoll.h>
++#endif
++int main(int argc, char **argv)
+ {
+ int epfd = epoll_create(256);
+ exit (epfd == -1 ? 1 : 0);
+@@ -1551,6 +1555,9 @@ dnl esac
+ AC_CACHE_CHECK([if select yields when using pthreads],
+ ol_cv_pthread_select_yields,[
+ AC_RUN_IFELSE([AC_LANG_SOURCE([[
++#define _XOPEN_SOURCE 500 /* For pthread_setconcurrency() on glibc */
++#include <stdlib.h>
++#include <stdio.h>
+ #include <sys/types.h>
+ #include <sys/time.h>
+ #include <unistd.h>
+@@ -1561,8 +1568,7 @@ dnl esac
+
+ static int fildes[2];
+
+-static void *task(p)
+- void *p;
++static void *task(void *p)
+ {
+ int i;
+ struct timeval tv;
+@@ -1586,9 +1592,7 @@ static void *task(p)
+ exit(0); /* if we exit here, the select blocked the whole process */
+ }
+
+-int main(argc, argv)
+- int argc;
+- char **argv;
++int main(int argc, char **argv)
+ {
+ pthread_t t;
+
+--- a/contrib/ldaptcl/tclAppInit.c
++++ b/contrib/ldaptcl/tclAppInit.c
+@@ -45,9 +45,7 @@ EXTERN int Tcltest_Init _ANSI_ARGS_((Tcl_Interp *interp));
+ */
+
+ int
+-main(argc, argv)
+- int argc; /* Number of command-line arguments. */
+- char **argv; /* Values of command-line arguments. */
++main(int argc, char **argv)
+ {
+ #ifdef USE_TCLX
+ TclX_Main(argc, argv, Tcl_AppInit);
+--- a/contrib/ldaptcl/tkAppInit.c
++++ b/contrib/ldaptcl/tkAppInit.c
+@@ -37,16 +37,9 @@ int (*tclDummyMathPtr)() = matherr;
+ * This is the main program for the application.
+ *-----------------------------------------------------------------------------
+ */
+-#ifdef __cplusplus
+ int
+ main (int argc,
+ char **argv)
+-#else
+-int
+-main (argc, argv)
+- int argc;
+- char **argv;
+-#endif
+ {
+ #ifdef USE_TCLX
+ TkX_Main(argc, argv, Tcl_AppInit);
+@@ -68,14 +61,8 @@ main (argc, argv)
+ * interp->result if an error occurs.
+ *-----------------------------------------------------------------------------
+ */
+-#ifdef __cplusplus
+ int
+ Tcl_AppInit (Tcl_Interp *interp)
+-#else
+-int
+-Tcl_AppInit (interp)
+- Tcl_Interp *interp;
+-#endif
+ {
+ if (Tcl_Init (interp) == TCL_ERROR) {
+ return TCL_ERROR;
+--- a/servers/slapd/syslog.c
++++ b/servers/slapd/syslog.c
+@@ -209,7 +209,7 @@ openlog(const char *ident, int logstat, int logfac)
+ }
+
+ void
+-closelog()
++closelog(void)
+ {
+ (void)close(LogFile);
+ LogFile = -1;