summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormio <miyopan@e.email>2024-09-06 18:32:31 +0000
committerCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-09-07 02:33:35 +0000
commitb36598accafc17f7879bdf39a4b5cc093be72284 (patch)
tree7eec58e6bee30674f43fadd7fed8d7891ecfd9a6
parent1a6031edf5cbda2c9ab5814b468927143fa0edd2 (diff)
downloadaports-b36598accafc17f7879bdf39a4b5cc093be72284.zip
community/weston: fix linting issues
-rw-r--r--community/weston/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/community/weston/APKBUILD b/community/weston/APKBUILD
index 26e45de06a7..8aa81461298 100644
--- a/community/weston/APKBUILD
+++ b/community/weston/APKBUILD
@@ -124,13 +124,13 @@ _sub() {
local name path
case $subpkgname in
*-shell-*)
- name=${subpkgname#$pkgname-shell-}
+ name=${subpkgname#"$pkgname"-shell-}
path=/usr/lib/$pkgname
pkgdesc="Weston shell: $name"
- name=*$name-shell*
+ name="*$name-shell*"
;;
*-backend-*)
- name=${subpkgname#$pkgname-backend-}
+ name=${subpkgname#"$pkgname"-backend-}
path=/usr/lib/$_libdir
pkgdesc="Weston backend: $name"
name=$name-backend.so
@@ -139,7 +139,7 @@ _sub() {
*)
name=$subpkgname
path=/usr/bin
- [ -x "$pkgdir"/$path/$name ] || name=${subpkgname#$pkgname-}
+ [ -x "$pkgdir"/$path/$name ] || name=${subpkgname#"$pkgname"-}
pkgdesc="Weston client: $name"
;;
esac