summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormio <miyopan@e.email>2024-09-06 22:34:42 +0000
committerCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-09-07 01:17:05 +0000
commit9b5c31a660c62240a7fa9e28260617cc6416a149 (patch)
treef4fb0a6c3e5ef4775a89212bb9d520a15ce50c76
parent0a738212517ac18a6ce49efc80c4917a7ce05607 (diff)
downloadaports-9b5c31a660c62240a7fa9e28260617cc6416a149.zip
community/libretro-craft: fix build with gcc 14
-rw-r--r--community/libretro-craft/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/community/libretro-craft/APKBUILD b/community/libretro-craft/APKBUILD
index de11063d9b9..3f39256517d 100644
--- a/community/libretro-craft/APKBUILD
+++ b/community/libretro-craft/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: David Demelier <markand@malikania.fr>
pkgname=libretro-craft
pkgver=0_git20230109
-pkgrel=0
+pkgrel=1
_commit="fce88570e83003b24cce34085928c890adae141d"
pkgdesc="a simple Minecraft clone written in C using modern OpenGL"
url="https://github.com/libretro/Craft"
@@ -14,6 +14,8 @@ builddir="$srcdir/Craft-$_commit"
options="!check" # No tests
build() {
+ # Enable POSIX features with -D_DEFAULT_SOURCE
+ export CFLAGS="$CFLAGS -D_DEFAULT_SOURCE"
make -f Makefile.libretro
}