summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-09-06 06:37:03 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2024-09-06 10:36:19 +0000
commit63bcfbdc587fa0bd09ab775d70f0cc6c190813bb (patch)
tree3b85f4c704610f476f3d81b43e97f6a79c4a3b90
parent537d5253c678ecc78cd70026f3880ca4410fd3a2 (diff)
downloadaports-63bcfbdc587fa0bd09ab775d70f0cc6c190813bb.zip
community/py3-simframe: upgrade to 1.0.5
-rw-r--r--community/py3-simframe/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/community/py3-simframe/APKBUILD b/community/py3-simframe/APKBUILD
index 8c340423f01..770c68e94da 100644
--- a/community/py3-simframe/APKBUILD
+++ b/community/py3-simframe/APKBUILD
@@ -2,15 +2,15 @@
# Maintainer: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
pkgname=py3-simframe
_pkgorig=simframe
-pkgver=1.0.4
-pkgrel=3
+pkgver=1.0.5
+pkgrel=0
pkgdesc="Python framework for setting up and running scientific simulations"
url="https://github.com/stammler/simframe/"
arch="noarch !armhf !armv7 !x86" #py3-h5py
license="BSD-3-Clause"
depends="python3 py3-dill py3-h5py py3-matplotlib py3-scipy py3-numpy"
checkdepends="py3-pytest-xdist"
-makedepends="py3-gpep517 py3-setuptools py3-wheel"
+makedepends="py3-gpep517 py3-meson-python python3-dev"
subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/stammler/$_pkgorig/archive/$pkgver/$_pkgorig-$pkgver.tar.gz"
builddir="$srcdir/$_pkgorig-$pkgver"
@@ -22,7 +22,10 @@ build() {
}
check() {
- python3 -m pytest --deselect tests/frame/test_group.py::test_group_memory_usage
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest \
+ --deselect tests/frame/test_group.py::test_group_memory_usage
}
package() {
@@ -33,5 +36,5 @@ package() {
}
sha512sums="
-4e992cce86dff3d7e29b1049f0397a9c15791a112383914ceed7c50500721c4d358a25862c61c4c25d46db47a7fa049263cbfbfa2b00cf2a34f6d3c6d7a87b9c py3-simframe-1.0.4.tar.gz
+0c95c94e4ff6575376507e1b8e0deff071c1866f9d556f9d72da11797f8fefe70298232c07d6c50543d9aa54b475ef91771bdcc5a39462bae3b39629027699bf py3-simframe-1.0.5.tar.gz
"