summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2015-03-12 13:40:26 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2015-03-12 13:40:26 +0000
commitdd0b5e868207b455fb2552ea019ed04d3bbf2ce5 (patch)
treed2f972edd149a157e441b3672ae4390f99635136
parentc97f05a3990d8ca8987b89ada273b84acd90a60f (diff)
downloadaports-dd0b5e868207b455fb2552ea019ed04d3bbf2ce5.zip
testing/sniproxy: new aport
Proxies incoming HTTP and TLS connections based on the hostname contained in the initial request of the TCP session.
-rw-r--r--testing/sniproxy/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/sniproxy/APKBUILD b/testing/sniproxy/APKBUILD
new file mode 100644
index 00000000000..91b7bbcf1ae
--- /dev/null
+++ b/testing/sniproxy/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=sniproxy
+pkgver=0.3.6
+pkgrel=0
+pkgdesc="Proxies incoming HTTP and TLS connections based on the hostname
+ contained in the initial request of the TCP session."
+url="https://github.com/dlundquist/sniproxy"
+arch="all"
+license="GPL"
+depends=
+depends_dev=
+makedepends="$depends_dev autoconf automake bsd-compat-headers gettext-dev
+ libev-dev libtool pcre-dev udns-dev
+ "
+install=
+subpackages="$pkgname-doc"
+source="https://github.com/dlundquist/$pkgname/archive/$pkgver.tar.gz"
+
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./autogen.sh && ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="52a01eb55ac7712de2dd13f1ba6260e4 0.3.6.tar.gz"
+sha256sums="90183ea5a380f1f946a9e0286334c916c2315bf005677ddc72f0afeed84a544c 0.3.6.tar.gz"
+sha512sums="5d2a3b181c3a710a5443c21d3c6181354e473c134e99a258b4d10dc452d449507d057ef65ad0586ecc43800b271fc03635f3d27a043855846248ca14e807781c 0.3.6.tar.gz"