summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-09-03 14:22:51 +0000
committerpsykose <alice@ayaya.dev>2022-09-03 16:22:52 +0200
commitd2e14c2a460ae77f9238bf5691fe3a1847628ec5 (patch)
treea19fc67727ad83bbea72ddaad0f93c9eb9f6848c
parentea512279afe238bcc2ea341604414aba94033a9a (diff)
downloadaports-d2e14c2a460ae77f9238bf5691fe3a1847628ec5.zip
testing/*: use meson test --print-errorlogs instead of -v
this is much less spammy in log output, as only actual errors are printed instead of everything
-rw-r--r--testing/adw-gtk3/APKBUILD2
-rw-r--r--testing/apostrophe/APKBUILD2
-rw-r--r--testing/c-dvar/APKBUILD2
-rw-r--r--testing/c-ini/APKBUILD2
-rw-r--r--testing/c-list/APKBUILD2
-rw-r--r--testing/c-rbtree/APKBUILD2
-rw-r--r--testing/c-shquote/APKBUILD2
-rw-r--r--testing/c-stdaux/APKBUILD2
-rw-r--r--testing/c-utf8/APKBUILD2
-rw-r--r--testing/clevis/APKBUILD2
-rw-r--r--testing/d-spy/APKBUILD2
-rw-r--r--testing/dpdk/APKBUILD2
-rw-r--r--testing/eartag/APKBUILD2
-rw-r--r--testing/eolie/APKBUILD2
-rw-r--r--testing/fastd/APKBUILD2
-rw-r--r--testing/geopard/APKBUILD2
-rw-r--r--testing/gst-rtsp-server/APKBUILD2
-rw-r--r--testing/gtkgreet/APKBUILD2
-rw-r--r--testing/igt-gpu-tools/APKBUILD2
-rw-r--r--testing/kooha/APKBUILD2
-rw-r--r--testing/libaudec/APKBUILD2
-rw-r--r--testing/libxml++/APKBUILD2
-rw-r--r--testing/lv2lint/APKBUILD2
-rw-r--r--testing/mda-lv2/APKBUILD2
-rw-r--r--testing/mrsh/APKBUILD2
-rw-r--r--testing/paprefs/APKBUILD2
-rw-r--r--testing/phosh-mobile-settings/APKBUILD2
-rw-r--r--testing/pinentry-bemenu/APKBUILD2
-rw-r--r--testing/piper/APKBUILD2
-rw-r--r--testing/planner/APKBUILD2
-rw-r--r--testing/ratbag/APKBUILD2
-rw-r--r--testing/razergenie/APKBUILD2
-rwxr-xr-xtesting/read-it-later/APKBUILD2
-rw-r--r--testing/rizin/APKBUILD2
-rw-r--r--testing/sane-airscan/APKBUILD2
-rw-r--r--testing/solanum/APKBUILD2
-rw-r--r--testing/tang/APKBUILD2
-rw-r--r--testing/vkmark/APKBUILD2
-rw-r--r--testing/waynergy/APKBUILD2
39 files changed, 39 insertions, 39 deletions
diff --git a/testing/adw-gtk3/APKBUILD b/testing/adw-gtk3/APKBUILD
index 4e332d2b786..0de15563463 100644
--- a/testing/adw-gtk3/APKBUILD
+++ b/testing/adw-gtk3/APKBUILD
@@ -18,7 +18,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/apostrophe/APKBUILD b/testing/apostrophe/APKBUILD
index d9019bacb93..2d5d58cd223 100644
--- a/testing/apostrophe/APKBUILD
+++ b/testing/apostrophe/APKBUILD
@@ -24,7 +24,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/c-dvar/APKBUILD b/testing/c-dvar/APKBUILD
index 0e47080b7c5..453196e5ab6 100644
--- a/testing/c-dvar/APKBUILD
+++ b/testing/c-dvar/APKBUILD
@@ -21,7 +21,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/c-ini/APKBUILD b/testing/c-ini/APKBUILD
index 8aa751a9917..a2f7ef6a5e2 100644
--- a/testing/c-ini/APKBUILD
+++ b/testing/c-ini/APKBUILD
@@ -23,7 +23,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/c-list/APKBUILD b/testing/c-list/APKBUILD
index 817f57035dc..c249e1c54e7 100644
--- a/testing/c-list/APKBUILD
+++ b/testing/c-list/APKBUILD
@@ -17,7 +17,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/c-rbtree/APKBUILD b/testing/c-rbtree/APKBUILD
index a2968c5b4b4..a25a3dade63 100644
--- a/testing/c-rbtree/APKBUILD
+++ b/testing/c-rbtree/APKBUILD
@@ -20,7 +20,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/c-shquote/APKBUILD b/testing/c-shquote/APKBUILD
index 8f717500cdb..1404a7a3af9 100644
--- a/testing/c-shquote/APKBUILD
+++ b/testing/c-shquote/APKBUILD
@@ -20,7 +20,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/c-stdaux/APKBUILD b/testing/c-stdaux/APKBUILD
index 05e64a5502d..30630d015d4 100644
--- a/testing/c-stdaux/APKBUILD
+++ b/testing/c-stdaux/APKBUILD
@@ -17,7 +17,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/c-utf8/APKBUILD b/testing/c-utf8/APKBUILD
index c8138c594e2..ebacfb7f00a 100644
--- a/testing/c-utf8/APKBUILD
+++ b/testing/c-utf8/APKBUILD
@@ -20,7 +20,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/clevis/APKBUILD b/testing/clevis/APKBUILD
index dad3e5337e1..1e2d310eb0e 100644
--- a/testing/clevis/APKBUILD
+++ b/testing/clevis/APKBUILD
@@ -37,7 +37,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/d-spy/APKBUILD b/testing/d-spy/APKBUILD
index 35007ef0f58..2caf589ffe9 100644
--- a/testing/d-spy/APKBUILD
+++ b/testing/d-spy/APKBUILD
@@ -18,7 +18,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/dpdk/APKBUILD b/testing/dpdk/APKBUILD
index d0c7a5da20c..c959af6a9b9 100644
--- a/testing/dpdk/APKBUILD
+++ b/testing/dpdk/APKBUILD
@@ -36,7 +36,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/eartag/APKBUILD b/testing/eartag/APKBUILD
index 31e99d63742..1733bbf16ba 100644
--- a/testing/eartag/APKBUILD
+++ b/testing/eartag/APKBUILD
@@ -19,7 +19,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/eolie/APKBUILD b/testing/eolie/APKBUILD
index 1cffec6b4d0..2c44bccf0b2 100644
--- a/testing/eolie/APKBUILD
+++ b/testing/eolie/APKBUILD
@@ -41,7 +41,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/fastd/APKBUILD b/testing/fastd/APKBUILD
index 84fc478c6a8..8ef577854c4 100644
--- a/testing/fastd/APKBUILD
+++ b/testing/fastd/APKBUILD
@@ -27,7 +27,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/geopard/APKBUILD b/testing/geopard/APKBUILD
index fffbff508bd..81b5550b9b7 100644
--- a/testing/geopard/APKBUILD
+++ b/testing/geopard/APKBUILD
@@ -31,7 +31,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/gst-rtsp-server/APKBUILD b/testing/gst-rtsp-server/APKBUILD
index 240481d26b9..03131ac99a5 100644
--- a/testing/gst-rtsp-server/APKBUILD
+++ b/testing/gst-rtsp-server/APKBUILD
@@ -24,7 +24,7 @@ build() {
}
check() {
- meson test -v --no-rebuild -C output
+ meson test --print-errorlogs --no-rebuild -C output
}
package() {
diff --git a/testing/gtkgreet/APKBUILD b/testing/gtkgreet/APKBUILD
index e516e3ee176..b7a20f5af54 100644
--- a/testing/gtkgreet/APKBUILD
+++ b/testing/gtkgreet/APKBUILD
@@ -29,7 +29,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/igt-gpu-tools/APKBUILD b/testing/igt-gpu-tools/APKBUILD
index bd2c8a4f861..f8008a4c648 100644
--- a/testing/igt-gpu-tools/APKBUILD
+++ b/testing/igt-gpu-tools/APKBUILD
@@ -28,7 +28,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C build
+ meson test --no-rebuild --print-errorlogs -C build
}
package() {
diff --git a/testing/kooha/APKBUILD b/testing/kooha/APKBUILD
index 5ce1691cbb1..9c63baa5823 100644
--- a/testing/kooha/APKBUILD
+++ b/testing/kooha/APKBUILD
@@ -52,7 +52,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/libaudec/APKBUILD b/testing/libaudec/APKBUILD
index b305f953b85..e45ac53e05b 100644
--- a/testing/libaudec/APKBUILD
+++ b/testing/libaudec/APKBUILD
@@ -24,7 +24,7 @@ build() {
}
check() {
- meson test -v --no-rebuild -C output
+ meson test --print-errorlogs --no-rebuild -C output
}
package() {
diff --git a/testing/libxml++/APKBUILD b/testing/libxml++/APKBUILD
index 0c9be67e674..d0643dd9e2f 100644
--- a/testing/libxml++/APKBUILD
+++ b/testing/libxml++/APKBUILD
@@ -21,7 +21,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/lv2lint/APKBUILD b/testing/lv2lint/APKBUILD
index 736b4da2307..16cea3214c5 100644
--- a/testing/lv2lint/APKBUILD
+++ b/testing/lv2lint/APKBUILD
@@ -25,7 +25,7 @@ build() {
}
check() {
- meson test -v --no-rebuild -C output
+ meson test --print-errorlogs --no-rebuild -C output
}
package() {
diff --git a/testing/mda-lv2/APKBUILD b/testing/mda-lv2/APKBUILD
index 91f272bd657..37174793643 100644
--- a/testing/mda-lv2/APKBUILD
+++ b/testing/mda-lv2/APKBUILD
@@ -20,7 +20,7 @@ build() {
}
check() {
- meson test -v --no-rebuild -C output
+ meson test --print-errorlogs --no-rebuild -C output
}
package() {
diff --git a/testing/mrsh/APKBUILD b/testing/mrsh/APKBUILD
index 55ae6106f43..61015406661 100644
--- a/testing/mrsh/APKBUILD
+++ b/testing/mrsh/APKBUILD
@@ -20,7 +20,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/paprefs/APKBUILD b/testing/paprefs/APKBUILD
index da0aa337fb9..69a2650c2a0 100644
--- a/testing/paprefs/APKBUILD
+++ b/testing/paprefs/APKBUILD
@@ -23,7 +23,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/phosh-mobile-settings/APKBUILD b/testing/phosh-mobile-settings/APKBUILD
index b575db4b050..d93120f5a1c 100644
--- a/testing/phosh-mobile-settings/APKBUILD
+++ b/testing/phosh-mobile-settings/APKBUILD
@@ -25,7 +25,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/pinentry-bemenu/APKBUILD b/testing/pinentry-bemenu/APKBUILD
index f011d00d090..fbe5f1d7192 100644
--- a/testing/pinentry-bemenu/APKBUILD
+++ b/testing/pinentry-bemenu/APKBUILD
@@ -26,7 +26,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/piper/APKBUILD b/testing/piper/APKBUILD
index be97d839da3..031306280ef 100644
--- a/testing/piper/APKBUILD
+++ b/testing/piper/APKBUILD
@@ -22,7 +22,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/planner/APKBUILD b/testing/planner/APKBUILD
index e56134a502c..1a782957c64 100644
--- a/testing/planner/APKBUILD
+++ b/testing/planner/APKBUILD
@@ -18,7 +18,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C build
+ meson test --no-rebuild --print-errorlogs -C build
}
package() {
diff --git a/testing/ratbag/APKBUILD b/testing/ratbag/APKBUILD
index 5a635e26b88..2a882dc6c88 100644
--- a/testing/ratbag/APKBUILD
+++ b/testing/ratbag/APKBUILD
@@ -36,7 +36,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/razergenie/APKBUILD b/testing/razergenie/APKBUILD
index c6c0d5df57d..a0245e767e4 100644
--- a/testing/razergenie/APKBUILD
+++ b/testing/razergenie/APKBUILD
@@ -23,7 +23,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/read-it-later/APKBUILD b/testing/read-it-later/APKBUILD
index c3c01524ab0..bb8931efa5e 100755
--- a/testing/read-it-later/APKBUILD
+++ b/testing/read-it-later/APKBUILD
@@ -24,7 +24,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/rizin/APKBUILD b/testing/rizin/APKBUILD
index f833b356b7a..aad72b50ea1 100644
--- a/testing/rizin/APKBUILD
+++ b/testing/rizin/APKBUILD
@@ -54,7 +54,7 @@ check() {
# Include the build rizin otherwise
# unit/test_rzpipe.c will fail
export PATH="$PATH:$builddir/output/binrz/rizin/"
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/sane-airscan/APKBUILD b/testing/sane-airscan/APKBUILD
index 4cc98fd9f99..f4a0e6e88cf 100644
--- a/testing/sane-airscan/APKBUILD
+++ b/testing/sane-airscan/APKBUILD
@@ -27,7 +27,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/solanum/APKBUILD b/testing/solanum/APKBUILD
index 11ad3620086..f378323096a 100644
--- a/testing/solanum/APKBUILD
+++ b/testing/solanum/APKBUILD
@@ -35,7 +35,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/tang/APKBUILD b/testing/tang/APKBUILD
index 13ab0f8210a..cb688b19360 100644
--- a/testing/tang/APKBUILD
+++ b/testing/tang/APKBUILD
@@ -30,7 +30,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
diff --git a/testing/vkmark/APKBUILD b/testing/vkmark/APKBUILD
index ef01079b750..0a66c6fe461 100644
--- a/testing/vkmark/APKBUILD
+++ b/testing/vkmark/APKBUILD
@@ -28,7 +28,7 @@ build() {
check() {
# Skip failing "util image file reads" test
- meson test --no-rebuild -v -C output --test-args "exclude:Scenario: util image file reads"
+ meson test --no-rebuild --print-errorlogs -C output --test-args "exclude:Scenario: util image file reads"
}
package() {
diff --git a/testing/waynergy/APKBUILD b/testing/waynergy/APKBUILD
index 193ca63ba55..1b0bed8e51b 100644
--- a/testing/waynergy/APKBUILD
+++ b/testing/waynergy/APKBUILD
@@ -23,7 +23,7 @@ build() {
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {