summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2024-08-14 19:09:09 +0200
committerSören Tempel <soeren+alpine@soeren-tempel.net>2024-09-06 20:42:11 +0000
commitbdd1f26e214d07e50d90e9bd56432e86884fa843 (patch)
tree70f9b0554117b1039c103ebb8ae0f145fc6f99a1
parent565d99dfabbaced54ae20ed89a4d521d78cc020d (diff)
downloadaports-bdd1f26e214d07e50d90e9bd56432e86884fa843.zip
community/go: upgrade to 1.23.1
-rw-r--r--community/go/0002-go.env-Don-t-switch-Go-toolchain-version-as-directed.patch (renamed from community/go/0003-go.env-Don-t-switch-Go-toolchain-version-as-directed.patch)0
-rw-r--r--community/go/0002-misc-cgo-test-enable-setgid-tests-on-Alpine-Linux-ag.patch52
-rw-r--r--community/go/0004-cmd-dist-cmd-go-define-assembly-macros-handle-GOARM-.patch73
-rw-r--r--community/go/0005-cmd-link-internal-loong64-correct-the-musl-dynamic-l.patch40
-rw-r--r--community/go/0006-fix-loong64-the-musl-dynamic-linker-name.patch29
-rw-r--r--community/go/APKBUILD20
6 files changed, 8 insertions, 206 deletions
diff --git a/community/go/0003-go.env-Don-t-switch-Go-toolchain-version-as-directed.patch b/community/go/0002-go.env-Don-t-switch-Go-toolchain-version-as-directed.patch
index db823307457..db823307457 100644
--- a/community/go/0003-go.env-Don-t-switch-Go-toolchain-version-as-directed.patch
+++ b/community/go/0002-go.env-Don-t-switch-Go-toolchain-version-as-directed.patch
diff --git a/community/go/0002-misc-cgo-test-enable-setgid-tests-on-Alpine-Linux-ag.patch b/community/go/0002-misc-cgo-test-enable-setgid-tests-on-Alpine-Linux-ag.patch
deleted file mode 100644
index cfbda574369..00000000000
--- a/community/go/0002-misc-cgo-test-enable-setgid-tests-on-Alpine-Linux-ag.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From b10f7f53b8a2b5d050b87072672bd7dfb79d6c1e Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
-Date: Wed, 7 Jun 2023 23:42:05 +0200
-Subject: [PATCH] misc/cgo/test: enable setgid tests on Alpine Linux again
-
-The underlying issue has been fixed in musl.
----
- src/cmd/cgo/internal/test/cgo_linux_test.go | 10 ----------
- 1 file changed, 10 deletions(-)
-
-diff --git a/src/cmd/cgo/internal/test/cgo_linux_test.go b/src/cmd/cgo/internal/test/cgo_linux_test.go
-index 3defc32ffd..21b1feb5d1 100644
---- a/src/cmd/cgo/internal/test/cgo_linux_test.go
-+++ b/src/cmd/cgo/internal/test/cgo_linux_test.go
-@@ -7,7 +7,6 @@
- package cgotest
-
- import (
-- "os"
- "runtime"
- "testing"
- )
-@@ -16,9 +15,6 @@ func TestSetgid(t *testing.T) {
- if runtime.GOOS == "android" {
- t.Skip("unsupported on Android")
- }
-- if _, err := os.Stat("/etc/alpine-release"); err == nil {
-- t.Skip("setgid is broken with musl libc - go.dev/issue/39857")
-- }
- testSetgid(t)
- }
-
-@@ -26,9 +22,6 @@ func TestSetgidStress(t *testing.T) {
- if runtime.GOOS == "android" {
- t.Skip("unsupported on Android")
- }
-- if _, err := os.Stat("/etc/alpine-release"); err == nil {
-- t.Skip("setgid is broken with musl libc - go.dev/issue/39857")
-- }
- testSetgidStress(t)
- }
-
-@@ -36,9 +29,6 @@ func Test1435(t *testing.T) { test1435(t) }
- func Test6997(t *testing.T) { test6997(t) }
-
- func Test9400(t *testing.T) {
-- if _, err := os.Stat("/etc/alpine-release"); err == nil {
-- t.Skip("setgid is broken with musl libc - go.dev/issue/39857")
-- }
- test9400(t)
- }
-
diff --git a/community/go/0004-cmd-dist-cmd-go-define-assembly-macros-handle-GOARM-.patch b/community/go/0004-cmd-dist-cmd-go-define-assembly-macros-handle-GOARM-.patch
deleted file mode 100644
index 3ed418b3484..00000000000
--- a/community/go/0004-cmd-dist-cmd-go-define-assembly-macros-handle-GOARM-.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-From b1a26c61c6f321bacfcf6d44950d759af1f926b0 Mon Sep 17 00:00:00 2001
-From: Cherry Mui <cherryyz@google.com>
-Date: Fri, 9 Feb 2024 01:15:18 -0500
-Subject: [PATCH] cmd/dist,cmd/go: define assembly macros, handle GOARM value
- with soft/hardfloat
-
-CL 525637 added GOARM_x assembly macros based on GOARM value. But
-it did not define the macro in cmd/dist, so the macro is not set
-during bootstrapping. This CL defines them.
-
-With CL 514907, cfg.GOARM can also take a soft/hardfloat suffix,
-like "7,hardfloat". Handle that case.
-
-For #65601.
-
-Change-Id: I60ffe7e8b623ae693d91d6e8595067a6f76565b3
-Reviewed-on: https://go-review.googlesource.com/c/go/+/562995
-Run-TryBot: Cherry Mui <cherryyz@google.com>
-Reviewed-by: Keith Randall <khr@golang.org>
-Reviewed-by: Keith Randall <khr@google.com>
-TryBot-Result: Gopher Robot <gobot@golang.org>
----
- src/cmd/dist/build.go | 14 ++++++++++++++
- src/cmd/go/internal/work/gc.go | 9 +++++----
- 2 files changed, 19 insertions(+), 4 deletions(-)
-
-diff --git a/src/cmd/dist/build.go b/src/cmd/dist/build.go
-index 32e59b446a..04c950fcb2 100644
---- a/src/cmd/dist/build.go
-+++ b/src/cmd/dist/build.go
-@@ -891,6 +891,20 @@ func runInstall(pkg string, ch chan struct{}) {
- asmArgs = append(asmArgs, "-D", "GOPPC64_power8")
- }
- }
-+ if goarch == "arm" {
-+ // Define GOARM_value from goarm, which can be either a version
-+ // like "6", or a version and a FP mode, like "7,hardfloat".
-+ switch {
-+ case strings.Contains(goarm, "7"):
-+ asmArgs = append(asmArgs, "-D", "GOARM_7")
-+ fallthrough
-+ case strings.Contains(goarm, "6"):
-+ asmArgs = append(asmArgs, "-D", "GOARM_6")
-+ fallthrough
-+ default:
-+ asmArgs = append(asmArgs, "-D", "GOARM_5")
-+ }
-+ }
- goasmh := pathf("%s/go_asm.h", workdir)
-
- // Collect symabis from assembly code.
-diff --git a/src/cmd/go/internal/work/gc.go b/src/cmd/go/internal/work/gc.go
-index e2a5456bde..6971696adb 100644
---- a/src/cmd/go/internal/work/gc.go
-+++ b/src/cmd/go/internal/work/gc.go
-@@ -362,12 +362,13 @@ func asmArgs(a *Action, p *load.Package) []any {
- }
-
- if cfg.Goarch == "arm" {
-- // Define GOARM_value from cfg.GOARM.
-- switch cfg.GOARM {
-- case "7":
-+ // Define GOARM_value from cfg.GOARM, which can be either a version
-+ // like "6", or a version and a FP mode, like "7,hardfloat".
-+ switch {
-+ case strings.Contains(cfg.GOARM, "7"):
- args = append(args, "-D", "GOARM_7")
- fallthrough
-- case "6":
-+ case strings.Contains(cfg.GOARM, "6"):
- args = append(args, "-D", "GOARM_6")
- fallthrough
- default:
diff --git a/community/go/0005-cmd-link-internal-loong64-correct-the-musl-dynamic-l.patch b/community/go/0005-cmd-link-internal-loong64-correct-the-musl-dynamic-l.patch
deleted file mode 100644
index 6c7c3fbca2f..00000000000
--- a/community/go/0005-cmd-link-internal-loong64-correct-the-musl-dynamic-l.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 128a99decdfd697f6426e3ee651e852081dd7ac5 Mon Sep 17 00:00:00 2001
-From: limeidan <limeidan@loongson.cn>
-Date: Fri, 1 Mar 2024 11:13:21 +0800
-Subject: [PATCH] cmd/link/internal/loong64: correct the musl dynamic linker
- path
-
-Musl libc already supports loongarch64, the dynamic linker path is the
-same as other architectures: /lib/ld-musl-$ARCH.so.1
-
-Ref: https://git.musl-libc.org/cgit/musl/tree/INSTALL#n141
-
-Change-Id: Ie31d4254f6e14a5d634b2a7b5fa4c6270e2c0dc7
-Reviewed-on: https://go-review.googlesource.com/c/go/+/569475
-Reviewed-by: Cherry Mui <cherryyz@google.com>
-Auto-Submit: Cherry Mui <cherryyz@google.com>
-Reviewed-by: Than McIntosh <thanm@google.com>
-LUCI-TryBot-Result: Go LUCI <golang-scoped@luci-project-accounts.iam.gserviceaccount.com>
-Reviewed-by: abner chenc <chenguoqi@loongson.cn>
-Reviewed-by: sophie zhao <zhaoxiaolin@loongson.cn>
-Reviewed-by: Qiqi Huang <huangqiqi@loongson.cn>
----
- src/cmd/link/internal/loong64/obj.go | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/cmd/link/internal/loong64/obj.go b/src/cmd/link/internal/loong64/obj.go
-index b68ed494f6..06ac5302cc 100644
---- a/src/cmd/link/internal/loong64/obj.go
-+++ b/src/cmd/link/internal/loong64/obj.go
-@@ -30,7 +30,7 @@ func Init() (*sys.Arch, ld.Arch) {
-
- ELF: ld.ELFArch{
- Linuxdynld: "/lib64/ld-linux-loongarch-lp64d.so.1",
-- LinuxdynldMusl: "/lib64/ld-musl-loongarch.so.1",
-+ LinuxdynldMusl: "/lib/ld-musl-loongarch.so.1",
- Freebsddynld: "XXX",
- Openbsddynld: "XXX",
- Netbsddynld: "XXX",
---
-2.45.1
-
diff --git a/community/go/0006-fix-loong64-the-musl-dynamic-linker-name.patch b/community/go/0006-fix-loong64-the-musl-dynamic-linker-name.patch
deleted file mode 100644
index 9e54a7493b0..00000000000
--- a/community/go/0006-fix-loong64-the-musl-dynamic-linker-name.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 0fc2726709bbf4c17151e92e269f7bd6ab789378 Mon Sep 17 00:00:00 2001
-From: limeidan <limeidan@loongson.cn>
-Date: Wed, 5 Jun 2024 11:53:35 +0800
-Subject: [PATCH] cmd/link/internal/loong64: correct the musl dynamic linker
- path
-
-The arch name of loong64 should be loongarch64
-
-Change-Id: Ic5cf0f0274262a164bba78c426813a8b8851033b
----
- src/cmd/link/internal/loong64/obj.go | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/cmd/link/internal/loong64/obj.go b/src/cmd/link/internal/loong64/obj.go
-index 06ac5302cc..79c4c74fd3 100644
---- a/src/cmd/link/internal/loong64/obj.go
-+++ b/src/cmd/link/internal/loong64/obj.go
-@@ -30,7 +30,7 @@ func Init() (*sys.Arch, ld.Arch) {
-
- ELF: ld.ELFArch{
- Linuxdynld: "/lib64/ld-linux-loongarch-lp64d.so.1",
-- LinuxdynldMusl: "/lib/ld-musl-loongarch.so.1",
-+ LinuxdynldMusl: "/lib/ld-musl-loongarch64.so.1",
- Freebsddynld: "XXX",
- Openbsddynld: "XXX",
- Netbsddynld: "XXX",
---
-2.38.1
-
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index cfd7ea6a196..56bbe9a9cf4 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=go
# go binaries are statically linked, security updates require rebuilds
-pkgver=1.22.6
+pkgver=1.23.1
pkgrel=0
pkgdesc="Go programming language compiler"
url="https://go.dev/"
@@ -16,11 +16,7 @@ checkdepends="binutils-gold git git-daemon"
subpackages="$pkgname-doc"
source="https://go.dev/dl/go$pkgver.src.tar.gz
0001-cmd-link-prefer-musl-s-over-glibc-s-ld.so-during-dyn.patch
- 0002-misc-cgo-test-enable-setgid-tests-on-Alpine-Linux-ag.patch
- 0003-go.env-Don-t-switch-Go-toolchain-version-as-directed.patch
- 0004-cmd-dist-cmd-go-define-assembly-macros-handle-GOARM-.patch
- 0005-cmd-link-internal-loong64-correct-the-musl-dynamic-l.patch
- 0006-fix-loong64-the-musl-dynamic-linker-name.patch
+ 0002-go.env-Don-t-switch-Go-toolchain-version-as-directed.patch
tests-fchmodat-not-supported.patch
"
@@ -38,6 +34,10 @@ esac
# - CVE-2022-41720
# - CVE-2022-41722
# - CVE-2024-24787
+# 1.23.1-r0:
+# - CVE-2024-34155
+# - CVE-2024-34156
+# - CVE-2024-34158
# 1.22.5-r0:
# - CVE-2024-24791
# 1.22.4-r0:
@@ -300,12 +300,8 @@ package() {
-exec rm -rf \{\} \+
}
sha512sums="
-59f84ba390203271d9fe2d3f04624449d54d3bb73c2b6e54b5f7dc9e9e2dce2192bae07ef56a2afee871cff84d457b90f8a00f4433e072028b97af987f3799e1 go1.22.6.src.tar.gz
+c1db053bab03c33b4ec4cbef6c8dfae279542cde433fdb787b564ccf797bb9ac6d191aae3152a860a9539956502f31003f746e924287040849afce5ccaaf0988 go1.23.1.src.tar.gz
34dbe032c5f08dd8a7aad36fc4d54e746a876fdadc25466888a2f04f5a9d53103190ebd68d3cf978d3a041976185e30ffb25611fb577d031c159810d2d4c7c41 0001-cmd-link-prefer-musl-s-over-glibc-s-ld.so-during-dyn.patch
-89ab4fbb2901d3907e9661dce877ee45b4a4ee07b964dca341235420ee08764f49aed5da1596d28c649e349af19ea49c03ab6f2c2ad7588a4cf950a619c10e9b 0002-misc-cgo-test-enable-setgid-tests-on-Alpine-Linux-ag.patch
-8061e4ef9d7dd31804bd8d98c95afa5dd82567940b3436f45f874e0419e324b49713d8a814df04617e575ec3c6155199c4661352ea8aef63ead81ca3020f3dc4 0003-go.env-Don-t-switch-Go-toolchain-version-as-directed.patch
-a69a836364be8857f153b606769a155d89fdbbac39af6fbbc3cd923e95a15805f7497d6fdce6176a18a9ccee867946a03b809d8a4a32765dd20086115f179929 0004-cmd-dist-cmd-go-define-assembly-macros-handle-GOARM-.patch
-f1d8bea518b41309fce104078e52af7acdff033d0de9fa83f6f929da2b425424cc76ac913017d3c6a82b6e7600333a69bffe48189fc44aada6b859da446eb959 0005-cmd-link-internal-loong64-correct-the-musl-dynamic-l.patch
-2a00c761cf327b06a13f97de9179d7229f855c5f6c58277a62c4f5d3ee49ed6d6cfc3418ab918ea80e8089d9847a22aeba4e7df0956d863b56615e3a80c5d7cf 0006-fix-loong64-the-musl-dynamic-linker-name.patch
+8061e4ef9d7dd31804bd8d98c95afa5dd82567940b3436f45f874e0419e324b49713d8a814df04617e575ec3c6155199c4661352ea8aef63ead81ca3020f3dc4 0002-go.env-Don-t-switch-Go-toolchain-version-as-directed.patch
33ecefca77fa0af52a3b2b66a76977af27a88c8dddb89f03e0a5ae6794b9aac53a62d7be33020b49022e9a89d4cdfa383038ee10e160eb94548b2430bf3cfb5e tests-fchmodat-not-supported.patch
"