summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-27 20:38:36 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-27 20:38:36 +0100
commita67c8aa673dc17b5beab81605740830f33e9ccc7 (patch)
tree2dae3c105f575aad1a65df4520519328291f0048
parentf947a4ce545f86c654464ba4909329a9e156c4a5 (diff)
downloadaports-a67c8aa673dc17b5beab81605740830f33e9ccc7.zip
main/perl-test-without-module: modernize
-rw-r--r--main/perl-test-without-module/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/main/perl-test-without-module/APKBUILD b/main/perl-test-without-module/APKBUILD
index dfb06ec3049..f525492cc28 100644
--- a/main/perl-test-without-module/APKBUILD
+++ b/main/perl-test-without-module/APKBUILD
@@ -2,30 +2,28 @@
pkgname=perl-test-without-module
_pkgreal="Test-Without-Module"
pkgver=0.20
-pkgrel=0
+pkgrel=1
pkgdesc="Test::Without::Module perl module"
-url="http://search.cpan.org"
+url="https://metacpan.org/pod/Test::Without::Module"
arch="noarch"
-license="GPL or Artistic"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/C/CO/CORION/Test-Without-Module-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/C/CO/CORION/Test-Without-Module-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgreal-$pkgver
check() {
- cd "$builddir"
make test
}
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}