summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKaarle Ritvanen <kunkku@alpinelinux.org>2024-05-13 20:23:30 +0300
committerKaarle Ritvanen <kunkku@alpinelinux.org>2024-05-13 20:29:07 +0300
commit8886f3f34753c5f294387fa4d7597a20925cf9bd (patch)
tree3b9740dc7154f629833fe52b3a9cb2624983d7ee
parent141141383d7ba08966c70423db17bebe7f3a5452 (diff)
downloadaports-8886f3f34753c5f294387fa4d7597a20925cf9bd.zip
testing/py3-pyinstaller: new package
-rw-r--r--testing/py3-pyinstaller/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/py3-pyinstaller/APKBUILD b/testing/py3-pyinstaller/APKBUILD
new file mode 100644
index 00000000000..6386ef436e7
--- /dev/null
+++ b/testing/py3-pyinstaller/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Kaarle Ritvanen <kunkku@alpinelinux.org>
+pkgname=py3-pyinstaller
+pkgver=6.6.0
+pkgrel=0
+pkgdesc="PyInstaller bundles a Python application and all its dependencies into a single package"
+url="https://pyinstaller.org/"
+arch="noarch"
+license="(GPL-2.0-or-later WITH Bootloader-exception) AND Apache-2.0"
+depends="py3-altgraph py3-setuptools"
+makedepends="py3-gpep517 py3-wheel zlib-dev"
+options="!archcheck !check"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/p/pyinstaller/pyinstaller-$pkgver.tar.gz"
+builddir="$srcdir/pyinstaller-$pkgver"
+
+build() {
+ gpep517 build-wheel --wheel-dir .dist --output-fd 3 3>&1 >&2
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" .dist/*.whl
+}
+
+sha512sums="
+074658825ced3bd371fb34eea79fc62d9810da87a8ef88fbae7c68d38205c9956e9332c7eebaf94af9e1d337d3eca3df05ea6e9771e8497cfa6263b92dd44252 pyinstaller-6.6.0.tar.gz
+"