summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2023-12-27 12:17:08 +0100
committerSören Tempel <soeren+alpine@soeren-tempel.net>2023-12-27 11:25:39 +0000
commit8129a453ed916596c5314f706cbd041311647df5 (patch)
treefa309bb315d3ad67c0c647ffd9b2f1c86653666b
parent831900e4fcaafd4e5ba27272c228f5c557257bbf (diff)
downloadaports-8129a453ed916596c5314f706cbd041311647df5.zip
community/guile-git: add oid-type for git_diff struct model
-rw-r--r--community/guile-git/0001-Improve-compatibility-with-libgit2.patch18
-rw-r--r--community/guile-git/APKBUILD2
2 files changed, 14 insertions, 6 deletions
diff --git a/community/guile-git/0001-Improve-compatibility-with-libgit2.patch b/community/guile-git/0001-Improve-compatibility-with-libgit2.patch
index 61affe8dc5b..e2be857e855 100644
--- a/community/guile-git/0001-Improve-compatibility-with-libgit2.patch
+++ b/community/guile-git/0001-Improve-compatibility-with-libgit2.patch
@@ -1,6 +1,6 @@
-From e26c4d29ca2b62a31706ef9c00fcab018a9cd905 Mon Sep 17 00:00:00 2001
+From 9a098922c430024ce552d8c3844aada4058e4812 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
-Date: Fri, 4 Aug 2023 08:29:09 +0200
+Date: Wed, 27 Dec 2023 07:41:53 +0100
Subject: [PATCH] Improve compatibility with libgit2
This fixes various struct layout mismatches with libgit 1.7.0. These
@@ -8,11 +8,11 @@ mismatches actually results in test failures on *some* architectures.
See also: https://gitlab.com/guile-git/guile-git/-/merge_requests/32
---
- git/structs.scm | 12 +++++++++---
- 1 file changed, 9 insertions(+), 3 deletions(-)
+ git/structs.scm | 13 ++++++++++---
+ 1 file changed, 10 insertions(+), 3 deletions(-)
diff --git a/git/structs.scm b/git/structs.scm
-index ca51728..2c5282c 100644
+index ca51728..181e77a 100644
--- a/git/structs.scm
+++ b/git/structs.scm
@@ -135,7 +135,8 @@
@@ -62,3 +62,11 @@ index ca51728..2c5282c 100644
(custom-headers ,%strarray))))
(define-record-type <fetch-options>
+@@ -1002,6 +1008,7 @@ indexer progress record. PROC can cancel the on-going transfer by returning
+ (payload ,(bs:pointer void))
+ (context-lines ,uint32)
+ (interhunk-lines ,uint32)
++ (oid-type ,int)
+ (id-abbrev ,uint16)
+ (max-size ,int64) ;git_off_t
+ (old-prefix ,(bs:pointer uint8)) ;char*
diff --git a/community/guile-git/APKBUILD b/community/guile-git/APKBUILD
index 0fff69bcaba..7562c1801b5 100644
--- a/community/guile-git/APKBUILD
+++ b/community/guile-git/APKBUILD
@@ -46,7 +46,7 @@ package() {
sha512sums="
905e03323a65bd057a50fc75265446407b9b6263852d3fa947a261d66b00ded2965bdb883ec8585c4748a28a1e0ce762a41511004a69fd1b1649c4146703278c guile-git-v0.5.2.tar.bz2
-506be2410911b984e6df4460667c07789b304ecbc3994a566000aa5999c99ba8be9086d768784e54d94d203a794d225108a4dda24940dd1dbb15fe954ca88c22 0001-Improve-compatibility-with-libgit2.patch
+85653195a492c8d857371f4b54453a75b528af2db5bad839bd80c2e29054dafaffc2a26bed077b8563ea3a49c505eb367c674b373ccd42c1957f14c35aa7ba13 0001-Improve-compatibility-with-libgit2.patch
5c6225ca7a8b559c68ca2a78cf8a722951913fa51b6a65d86a80db43b03744b978b79e0f18a830c46b4d3326a1258b6530550389f7a5ada41c02c814f1b25ee2 0002-Add-sanitycheck-utility-to-ensure-libgit2-compatibil.patch
c06974da410781544afc108689c310c1ce2230da369f2fa03b5c5c49ca3f04ac456db0c3462cebac9324ad8d88a761f36e50c35a44c104f91fe495fc4dbd783e skip-ssh-tests.patch
"