summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-01-26 00:15:48 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2020-01-26 00:19:03 +0100
commit77fd8047eb04cae74aa61d87c24968b368d545b4 (patch)
tree5d8c0c9a441af5100a07a42bc757a0bee507007f
parent08f73aa0901f1a1f16d720b38bc37300f2cf0bb1 (diff)
downloadaports-77fd8047eb04cae74aa61d87c24968b368d545b4.zip
community/beets: add a -docs subpackage
Currently only includes the man pages. The HTML documentation could also be included in future versions of the package.
-rw-r--r--community/beets/APKBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/community/beets/APKBUILD b/community/beets/APKBUILD
index f381bb0e8bc..8dc80585440 100644
--- a/community/beets/APKBUILD
+++ b/community/beets/APKBUILD
@@ -3,22 +3,31 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=beets
pkgver=1.4.9
-pkgrel=1
+pkgrel=2
pkgdesc="Music library manager and MusicBrainz tagger"
options="!check" # Requires unpackaged dependencies
url="http://beets.io"
arch="noarch"
license="MIT"
+subpackages="$pkgname-doc"
+makedepends="py3-sphinx"
depends="python3 py3-mutagen py3-unidecode py3-musicbrainzngs py3-munkres
py3-setuptools py3-yaml py3-jellyfish py3-six"
source="https://github.com/sampsyo/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
build() {
- python3 setup.py build
+ # sdist := source distribution tarball, builds man pages
+ python3 setup.py build sdist
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+ local man
+ for man in man/*.?; do
+ install -Dm644 "$man" \
+ "$pkgdir"/usr/share/man/man${man##*.}/${man##*/}
+ done
}
sha512sums="616bad4ca3ecdd05d2f59846fd67215f476ce89cc34d63bc6351efcbaf1e33e5ca783cb8a716e8597b56a7e08e6a6dc15e64b51e89dd786bfb6c5d847f66de5a beets-1.4.9.tar.gz"