summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2024-08-07 14:47:14 +0200
committerptrcnull <git@ptrcnull.me>2024-08-07 14:47:14 +0200
commit40610e9f29c5a54728a06e5636c4d357a56cc506 (patch)
tree7524767728916247191c26422d69eb8621a95624
parent1219c29a2f9954a0bc0b53483209c0de3b7a4226 (diff)
downloadaports-40610e9f29c5a54728a06e5636c4d357a56cc506.zip
testing/py3-pymsgbox: build with gpep517
-rw-r--r--testing/py3-pymsgbox/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/testing/py3-pymsgbox/APKBUILD b/testing/py3-pymsgbox/APKBUILD
index 9206e134bdd..370c1490ecb 100644
--- a/testing/py3-pymsgbox/APKBUILD
+++ b/testing/py3-pymsgbox/APKBUILD
@@ -3,13 +3,13 @@ pkgname=py3-pymsgbox
pkgver=1.0.9
# no actual tags
_gitrev=ad76bd85a9cd2506a5417b82408c82ed60585421
-pkgrel=4
+pkgrel=5
pkgdesc="Simple, cross-platform, pure Python module to display message boxes, and just message boxes"
url="https://github.com/asweigart/PyMsgBox"
arch="noarch"
license="GPL-3.0-or-later"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517"
checkdepends="xvfb-run"
subpackages="$pkgname-pyc"
source="$pkgname-$_gitrev.tar.gz::https://github.com/asweigart/PyMsgBox/archive/$_gitrev.tar.gz"
@@ -17,17 +17,20 @@ builddir="$srcdir/PyMsgBox-$_gitrev"
options="!check" # circular with pyautogui
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$PWD/src" \
- xvfb-run -a \
- python3 tests/test_pymsgbox.py
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ gpep517 install-wheel --destdir .testenv --prefix '' .dist/*.whl
+ xvfb-run -a .testenv/bin/python3 tests/test_pymsgbox.py
}
package() {
- python3 setup.py install --skip-build --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="