summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2020-01-26 12:00:38 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-01-27 20:55:59 +0100
commit377a336d997fd781f08f437c576c1c3d7bbfc7a1 (patch)
tree7d1ceb8176dc70a28d7bd8af9514f717c4999c8b
parentd5aadcf312a12ee1d130f6db540dc43614429e70 (diff)
downloadaports-377a336d997fd781f08f437c576c1c3d7bbfc7a1.zip
community/py3-ruamel.yaml.clib: new aport
Upstream split the C code out of community/py3-ruamel.yaml into a separate package. In order for py3-ruamel.yaml and ansible-lint to stay in community this separate package needs to be in community. There are no tests enabled because they are not available in a stable download. The PyPI download doesn't include the tests. Although the [project activity page] on Sourceforge shows files released, the [files page] is empty. [project activity page]: https://sourceforge.net/projects/ruamel-yaml-clib/ [files page]: https://sourceforge.net/projects/ruamel-yaml-clib/files/
-rw-r--r--community/py3-ruamel.yaml.clib/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/py3-ruamel.yaml.clib/APKBUILD b/community/py3-ruamel.yaml.clib/APKBUILD
new file mode 100644
index 00000000000..c97519fc2c1
--- /dev/null
+++ b/community/py3-ruamel.yaml.clib/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Keith Maxwell <keith.maxwell@gmail.com>
+# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
+pkgname="py3-ruamel.yaml.clib"
+_pyname="ruamel.yaml.clib"
+pkgver="0.2.0"
+pkgrel=0
+pkgdesc="C version of reader, parser and emitter for ruamel.yaml"
+url="https://sourceforge.net/projects/ruamel-yaml-clib/"
+arch="all"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools python3-dev"
+options="!check" # tests aren't on PyPI, Sourceforge downloads disappeared
+source="https://files.pythonhosted.org/packages/source/r/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 -m pip install . --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="7d716e27963b97a1735ba7ff0e581f7ecdfa62725cc42def59ad0ccdf9e23a9f7dfbc3cac298bb3e29362535036b07ba0f523452d6f73248be53c69796637e34 ruamel.yaml.clib-0.2.0.tar.gz"