summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-08-13 06:19:22 +0000
committerCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-09-06 06:13:08 +0000
commit16180b0ecfe469f907d1f930b016156cffa634e1 (patch)
tree8c1d02bbed52968df7498f560666e0f2e34c18d4
parent1fa026816e18151796d687a8560b20e60ed34a7a (diff)
downloadaports-16180b0ecfe469f907d1f930b016156cffa634e1.zip
main/rust: do not build vendored lld
Based on https://blog.rust-lang.org/2024/05/17/enabling-rust-lld-on-linux.html it seems Rust is moving towards using LLD as default linker. Rust 1.81.0 beta4 attempts to build its own vendored LLD, which requires adding packages like cmake, samurai, and libxml2-dev to makedepends. Setting this option ensures we never accidentally build that. If we wanted to use LLD, we would give preference to system LLD instead.
-rw-r--r--main/rust/APKBUILD1
1 files changed, 1 insertions, 0 deletions
diff --git a/main/rust/APKBUILD b/main/rust/APKBUILD
index 0fce5ab91b9..dabaf51334b 100644
--- a/main/rust/APKBUILD
+++ b/main/rust/APKBUILD
@@ -275,6 +275,7 @@ build() {
--set="rust.deny-warnings=false" \
--set="rust.parallel-compiler=false" \
--set="rust.remap-debuginfo=true" \
+ --set="rust.lld=false" \
--set="rust.description=Alpine Linux $pkgver-r$pkgrel" \
$lto \
$local_rebuild \