summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2024-09-06 09:18:00 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2024-09-06 09:18:00 +0200
commit119c9dc41bf456a195288a791ccb65f81bcdd3c2 (patch)
tree789652e4108d38551c53f33c318e0fa11afa7b57
parented8448e144ae84145eb4a8163aa09315910dc938 (diff)
downloadaports-119c9dc41bf456a195288a791ccb65f81bcdd3c2.zip
community/telepathy-glib: fix build with gcc 14
-rw-r--r--community/telepathy-glib/APKBUILD4
-rw-r--r--community/telepathy-glib/gcc14.patch24
2 files changed, 27 insertions, 1 deletions
diff --git a/community/telepathy-glib/APKBUILD b/community/telepathy-glib/APKBUILD
index 15a367662cc..c7b2d212b41 100644
--- a/community/telepathy-glib/APKBUILD
+++ b/community/telepathy-glib/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=telepathy-glib
pkgver=0.24.2
-pkgrel=2
+pkgrel=3
pkgdesc="Library for GLib-based Telepathy components"
url="https://telepathy.freedesktop.org"
arch="all"
@@ -13,6 +13,7 @@ checkdepends="dbus"
subpackages="$pkgname-dev $pkgname-doc"
source="https://telepathy.freedesktop.org/releases/telepathy-glib/telepathy-glib-$pkgver.tar.gz
test-cm.patch
+ gcc14.patch
"
case "$CARCH" in
@@ -56,4 +57,5 @@ package() {
sha512sums="
736590c299b6522c41153e01e80d9bfdac1d4cbec646b28c9fba67a07429426ff2c8e38818f2cddd7ccdc38a061d210906f6e551f7a6059c34c4dd08b789b501 telepathy-glib-0.24.2.tar.gz
779ae9628367f25aeb6a3c3322ef5e14f7c4271ba592f42e9c4bd82235a2bf767f8fea6ef13d61c746eb1719bf8e74c54c8f4da6d170496a595b5c4b96a39c5d test-cm.patch
+1500d0c5999072639353b5aa42869f58dde07c542bc7d9bd8be13781c1e34a8e181e223189080f48dee1be985a596ca2fd347c76b6c875262689e79bf21686cb gcc14.patch
"
diff --git a/community/telepathy-glib/gcc14.patch b/community/telepathy-glib/gcc14.patch
new file mode 100644
index 00000000000..8aef14dd1bc
--- /dev/null
+++ b/community/telepathy-glib/gcc14.patch
@@ -0,0 +1,24 @@
+From 72412c944b771f3214ddc40fa9dea82cea3a5651 Mon Sep 17 00:00:00 2001
+From: Mamoru TASAKA <mtasaka@fedoraproject.org>
+Date: Fri, 2 Feb 2024 12:17:44 +0900
+Subject: [PATCH] fix: build fix with -Werror=incompatible-pointer-types
+
+gcc14 defaults to -Werror=incompatible-pointer-types .
+Fix build error with this option.
+---
+ telepathy-glib/protocol.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/telepathy-glib/protocol.c b/telepathy-glib/protocol.c
+index 88fdff382..25b36620b 100644
+--- a/telepathy-glib/protocol.c
++++ b/telepathy-glib/protocol.c
+@@ -1791,7 +1791,7 @@ _tp_protocol_parse_manager_file (GKeyFile *file,
+ i++;
+ }
+
+- param_specs = g_ptr_array_new_full (i, tp_value_array_free);
++ param_specs = g_ptr_array_new_full (i, (GDestroyNotify) tp_value_array_free);
+
+ for (key = keys; key != NULL && *key != NULL; key++)
+ {